Question

Failed to create a document in PandaDoc: Required field "Role: Client email" (r_Client_email) is missing.


Hi,

I am getting an error when i test my hubspot - Pandadoc zap, Any help would be much appreciated.

 

‘Failed to create a document in PandaDoc

Required field "Role: Client email" (r_Client_email) is missing.’

Troubleshoot error

 

9/20 of my tokens work, They go onto the document fine it is just 9 of them including email does not work so it is failing to send.

 

I contacted hubspot and they advised - 

‘I have been liaising with our developer team here internally on this for us:

  • Our team have shared that Zapier is fetching this information from Deals using HubSpot API. If the property is not appearing in Zapier, then this is most likely because Zapier is not sending the correct API requests.
  • The team have shared that you would need to troubleshoot this with Zapier as we have limited visibility into this from our side.
  • The Zapier engineer or support rep will need to check what API request is sent by Zapier and what response is returned.
  • The team have shared that it is highly likely that HubSpot’s API is returning the correct information it is most likely that Zapier is not reading these properties correctly or there is some other issue on their end.
  • Our team have shared that this is something that Zapier would need to troubleshoot as only they have visibility over what is sent between the two platforms and how it is sent.’

Thank you


2 replies

Userlevel 7
Badge +11

Hi @James1992, welcome to the Community!

This is very strange indeed. I took a look and couldn’t see any existing bug reports of this behaviour with the PandaDoc app, but it could just be that you’re the first to have come across this.

To help us to better identify what might be causing the error, can you share some screenshots showing what you’re seeing in Data In and Data Out sections of the errored PandaDoc action, within the Zap History? Please remove/hide any private information (like names, email addresses etc.) from the screenshots before sharing.

Looking forward to hearing from you on this! 🙂

Userlevel 7
Badge +14

Hi @James1992 

God question.

Based on the error, there email address (static/dynamic) for the Client Role was missing (blank/empty/null).

Required field "Role: Client email" (r_Client_email) is missing.’

Reply