Question

Failed to create a contact in Brevo Error from halted execution: Add or Update Contact >> Error (400): Invalid phone number (invalid_parameter)

  • 31 August 2023
  • 19 replies
  • 474 views

Hello,

I got this error when trying to update contacts between Wix Automations and Brevo. I figured the phone number needed to be reformatted, but adding that action didn’t help. This was a randomly generated contact for testing so I’m not sure if it just doesn’t like that it’s a fake number? Any other ideas of how to resolve? Thanks


19 replies

Userlevel 7
Badge +14

Hi @TUWDC 

Good question.

The attachments did not load.

 

Hopefully now?

Userlevel 7
Badge +14

@TUWDC 

Try mapping the output from Step 2 for the SMS field.

 

 

At first I didn’t understand as I’m new to this, but now I think I got it figured out. You meant Step 2 from the Numbers in Formatter by Zapier needs to be put in the SMS field, not the Contact Phone from Wix Automations.

Userlevel 7
Badge +14

@TUWDC 

Correct.

I’m having the same problem but I don’t understand the solution. I’ve been trying for hours now, would really appreciate some help. Here is pictures of everything:

 

 

Userlevel 7
Badge +14

Hi @nathanbilli 

For future reference, probably best to post your own topic with description and screenshots plus link to the topic you are referencing.

 

Check the field description (more) for guidance on how to format the phone number.

 

@Troy Tessalone I’m not sure what the description means. Sorry, I’m quite new, please can you let me know. Here’s some extra screenshots if it helps

 

Userlevel 7
Badge +14

@nathanbilli 

The issue may be related to using a fake phone number to test.

Try testing with a real phone number.

 

Damn, I tried and it still didn’t work. What else do you think it could be? @Troy Tessalone 

 

 

Userlevel 7
Badge +14

@nathanbilli 

We would need to have context of what phone number you tested with and the encountered error.

Perhaps try turning the Zap ON and testing live.

Then check your Zap Runs to see the DATA IN/OUT for each step to help you troubleshoot: https://zapier.com/app/history/

Yeah I tried running it live, it just didn’t work. Here’s the number and error that occurred when I tried a verified number (my number) @Troy Tessalone 

 

 

I also tried with the +44 version of my number and it did this
 

 

Userlevel 7
Badge +6

Hi there @nathanbilli,

I’m jumping in to see if I can help!

It appears that phone numbers need to be sent in E164 format for this to work. If you still see this error try including the country code.

Here are the acceptable number formats specified by Brevo’s documentation:

91xxxxxxxxxx

+91xxxxxxxxxx

0091xxxxxxxxxx

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Userlevel 1

I have exactly the same problem.

 

Has anyone found the solution?

Same problem here

Userlevel 7
Badge +6

Hi @pixalia and @YannisHaismann,

If you’re running into the error of “Invalid phone number error”. Could you please try these for me:

 

It appears that phone numbers need to be sent in E164 format for this to work. If you still see this error try including the country code.

Here are the acceptable number formats specified by Brevo’s documentation:

91xxxxxxxxxx

+91xxxxxxxxxx

0091xxxxxxxxxx

Kindly give it a try and let me know how it goes? I'll keep an eye out for your response!

Additionally, if you’re receiving the error of “Add or Update Contact >>
Error (400): Unable to update contact, SMS is already
associated with another Contact”
 The error suggests there might be another contact in SendinBlue with the same SMS value.

Please keep me posted!

Hello peps, so I have followed all the steps mentioned above to have output changed, add trigger for email and number (mobile) fetching is also proper. But still at action the brevo is unable to perform its action with absurd error. PFA SS can anyone help with their magic spells!!

Hoping to get answered!

Same problem here, Brevo does not take any data from Zapier unfortunately

Reply