Question

Facebook leads not reflected in Monday.com


My facebook leads are not being reflected in monday.com. I already did all the trouble shooting, the test zaps work, there is no status error, all the permissions are fine… I really have no idea any more what the problem could be. 


2 replies

Userlevel 7
Badge +11

Welcome to the Community, @adlerandpartners! 👋

Usually, if the Zap isn’t triggering for new leads added into Facebook then you’ll want to check the following:

  1. Your account permissions - while it may work when testing in the Zap Editor, Facebook needs certain permissions to be granted in order for the Zap to trigger. See What permissions do I need to use Facebook Lead Ads with Zapier?
  2. Is the correct form is selected? - was the selected form name changed or replaced since setting up the Zap? If so, you’ll need to reselect the form within the Zap.
  3. Is CRM access for Zapier properly set? - this is set automatically but it may have been removed or revoked by accident. In which case you’ll need to give CRM access again.

You can find out more about this here: I’m receiving new leads in Facebook, but my Zap is not running

In most cases the cause is that the permissions that aren’t quite right. I know you mentioned you’d checked the permissions already but did you make any changes to fix the permissions at all when checking? If so and you didn’t reconnect the Facebook account in the Zap afterwards, then that might be why it’s not working. In which case, reconnecting your Facebook account should help to get it working.

It looks like you’ve also reached out to our Support team about this, so ​if you try the above and are still running into issues I’d recommend continuing the conversation with them via email. They’ll be able to take a look into the logs for your Zap and investigate further.

Please do keep us updated on how you get on! 🙂

Userlevel 7
Badge +14

Hi @adlerandpartners 

Good question.

Other things to check…

  1. Is the Zap ON?
  2. Has there been new data since the Zap was turned ON?
    1. Zaps only work while turned ON for new data going forward.
  3. Check your Zap Runs for errors: https://zapier.com/app/history/

Reply