Best answer

Facebook Lead Ads- "An unknown error has occured"

  • 8 February 2023
  • 11 replies
  • 1356 views

Userlevel 1

I can’t connect facebook lead ads because i have error
“failed to fetch a lead form Facebook Lead Ads”


The problem only occurs when I want to combine the form with conditions.

Just like in the picture below

 

icon

Best answer by Danvers 13 February 2023, 18:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

11 replies

Userlevel 7
Badge +14

Hi @s4rrow 

Good question.

Help articles for using FB Lead Ads in Zaps: https://zapier.com/apps/facebook-lead-ads/help

Not sure if the “conditional” issue is documented.

If not, you can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 1

Hi @s4rrow 

Good question.

Help articles for using FB Lead Ads in Zaps: https://zapier.com/apps/facebook-lead-ads/help

Not sure if the “conditional” issue is documented.

If not, you can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Thanks for your reply, I've submitted a support ticket.

This error occurs only with conditional forms. With regular forms, everything works fine and correctly

Maybe it's a problem with the recent Graph API update?

I also use another system for integration and there I also receive an error with the text oAuth problem code 0

Userlevel 7
Badge +14

@s4rrow 

Yeah often Zap app integrations break when underlying API/webhook changes are made since Zap app integration updates usually lag and are reactive to such app changes.

Userlevel 1

I am having the same issue, we have a lot of Zaps running for Facebook lead ads, but the ones using questions with conditions suddenly stopped working.

 

I’ve opened a ticket with Zapier Support, I hope they can solve this. 

 

Something is strange on the Facebook platform too, it suddenly stopped showing  in the ads manager the preview of the forms with conditional questions.

Userlevel 1

I am having the same issue, we have a lot of Zaps running for Facebook lead ads, but the ones using questions with conditions suddenly stopped working.

 

I’ve opened a ticket with Zapier Support, I hope they can solve this. 

 

Something is strange on the Facebook platform too, it suddenly stopped showing  in the ads manager the preview of the forms with conditional questions.

Hello.

did you manage to solve this problem? Got any response from support?

Userlevel 1

I am having the same issue, we have a lot of Zaps running for Facebook lead ads, but the ones using questions with conditions suddenly stopped working.

 

I’ve opened a ticket with Zapier Support, I hope they can solve this. 

 

Something is strange on the Facebook platform too, it suddenly stopped showing  in the ads manager the preview of the forms with conditional questions.

Hello.

did you manage to solve this problem? Got any response from support?

 

Not yet, they are making sure that it is not a permission problem. I had to send a few screenshots from the Facebook Business Manager confirming that I have all the permissions needed, it is probably standard procedure. 

Userlevel 1

I am having the same issue, we have a lot of Zaps running for Facebook lead ads, but the ones using questions with conditions suddenly stopped working.

 

I’ve opened a ticket with Zapier Support, I hope they can solve this. 

 

Something is strange on the Facebook platform too, it suddenly stopped showing  in the ads manager the preview of the forms with conditional questions.

Hello.

did you manage to solve this problem? Got any response from support?

 

Not yet, they are making sure that it is not a permission problem. I had to send a few screenshots from the Facebook Business Manager confirming that I have all the permissions needed, it is probably standard procedure. 

 

 

I've checked everything too.
Unfortunately, I haven't found any solution to this problem.

So far I have a few conclusions:

1. The error occurs only for forms with conditional selection.
2. The preview of the form with the conditional selection is not displayed in the ad manager.
3. When editing in the ad manager, it is not possible to copy a form that contains a conditional selection. The screen gets stuck loading.
4. Other integration software, e.g. Zapier, Leadsbridge, Make, also have connection problems
5. Using the developer console, I can download these contacts manually. The API works fine. https://developers.facebook.com/tools/explorer

Userlevel 1

This problem on community facebook developer
https://developers.facebook.com/community/threads/5769510926501898/

Please upvote, and leave comment on this bug
@Troy Tessalone @jenonagy 

Userlevel 1

This problem on community facebook developer
https://developers.facebook.com/community/threads/5769510926501898/

Please upvote, and leave comment on this bug
@Troy Tessalone @jenonagy 

It definitely looks like a problem on the Facebook side. I upvoted it, I hope it will be solved :)

Userlevel 1

It seems like the issue has been solved for me, I don’t know how, but it is working now.

Did you manage to solve this problem? 

Userlevel 7
Badge +12

Hi everyone!

Y’all seem to have this pretty well figured out but to confirm - we did get some reports of users with conditional Facebook Lead Ads forms experiencing errors over the last week. 

From what we can see these errors have now stopped, though if you are still having trouble please don’t hesitate to reach out to the Support Team.