Best answer

Excel Data Refresh: Columns Not Populating & Custom Pill Mapping Not Working

  • 5 September 2023
  • 15 replies
  • 69 views

Userlevel 1

Hello, 

 

I am attempting to utilize an excel document in my OneDrive for lookup-values. The first step is successfully recognizing the excel document & all related fields within the table (See “FindRow”). 

 The subsequent steps to utilize the said columns are not populating (see “DataFieldsNotPopulating”).  Even after following the custom pill mapping steps (see “CustomPillMapping”), the resulting fields are not populating. 

 - in this example the custom pill was to pull form column E & the prior excel lookup step is 203356071 within the zap workflow, so the resulting custom pill coding I believe is: {{203356071_COL$E}}

 

Does anyone have any advise on additional steps I can take so the fields will be recognized? 

 

Thanks,

Joe

icon

Best answer by Troy Tessalone 5 September 2023, 20:05

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Userlevel 7
Badge +14

Hi @Joseph Esposito 

Good question.

When testing the Excel step, make sure to find a row that has the columns populated, so you can map those to the next Zap steps.

 

Userlevel 1

Hi @Troy Tessalone ,

 

The current excel has rows populated & the lookup is pointing to Column A, which is the “Tag” column. 

Userlevel 7
Badge +14

@Joseph Esposito 

Were you able to test the Excel step to successfully find and return a matching row?

The mapped Tags (tag1,tag2) for the Lookup Value don’t appear to match the Tag naming conventions in the Excel file.

Also, if there are multiple Tags, then that will likely results in 0 matched rows.

 

 

 

 

Userlevel 1

Yes, Tag functionality works correctly. Here is an example where it was able to find the resulting row & then the returning values were blank. 

Userlevel 7
Badge +14

@Joseph Esposito 

Can you show a screenshot of the DATA OUT from the Excel step?

This will shows the found Row ID.

 

Userlevel 1

Certainly, attached is a snip of the “Data Out” section. 

Userlevel 7
Badge +14

@Joseph Esposito 

In the Zap Editor when configuring the Zap steps, you can use the ‘Custom’ option to map dynamic variables between Zap steps.

Did you do that when you were configuring the Zap steps?

EXAMPLE

 

Userlevel 1

Hi @Troy Tessalone,

 

In this mapping instance there is no option for dynamic variables, only what is available in the dropdown menu. as you can see in the attached example, the columns from the prior excel lookup step is not populating, even though the prior steps are successful. 

 

In lieu of entering the variable you are able to enter the custom pill that should point to the correct column. In this instance i have tried using both the title of the column and the column name. Both fail:

 

The node pointing to the prior lookup: 203356069

Column E: Competitors

 

Ive tried the following:

{{203356069_COL$E}}

{{203356069_Competitors}} 

both fail. 

 

Userlevel 7
Badge +14

@Joseph Esposito 

Is there data in Row 1234 of the Excel file?

If yes, then provide a screenshot of that Excel Row.

 

Userlevel 7
Badge +14

@Joseph Esposito 

If you are trying to do use custom variable syntax, then you will need 2 underscores after the Step ID.

{{203356069__COL$E}}

{{203356069__Competitors}}

 

Userlevel 1

Nothing in Row 1234.

Userlevel 1

Hi @Troy Tessalone ,

 

I believe that was the missing piece, I will confirm once all updates are made!

Userlevel 7
Badge +14

@Joseph Esposito 

Make sure to test the Excel step to successfully find a matching row.

Userlevel 1

@Troy Tessalone 

 

I can confirm I was able to successfully test & deploy the update. thanks!

 

Joe

Userlevel 7
Badge +11

That’s brilliant news, @Joseph Esposito! Thanks so much for taking the time to come back here and confirm that Troy’s suggestion did the trick. It’s much appreciated! 🤗