Question

Eventbrite update issues: New second registration page with custom (required) questions not getting Zapped

  • 17 January 2024
  • 1 reply
  • 213 views

(I know this question has been written before- but none of the previous solutions are working)

Ever since Eventbrite updated their platform and changed their registration page to “increase ticket sales”, custom questions at registration (in my case Title and Company) are now being asked on a secondary check out page. 

The custom questions are not being pushed through my Zap. 

  • The questions are all required
  • Ticket checkout is set to “Buyer only”

When building the zap and testing it in the build mode, it works fine. But once published and running on its own, it will only push through the zap the initial “standard” eventbrite questions on registration page 1 (Name and email). 

I have attempted to push the Zap into both Salesforce and Airtable and both have the same issue. 

According to Eventbrite there is no way to change this or revert back to the old check out page. :(    I don’t like this for all kinds of reasons- primarily being that my Zap no longer works! 

Has any discovered a workaround? Any idea if this will be fixed? My entire paid plan is to support this Zap and really need to get this resolved. Thank you for any and all help! 


1 reply

Userlevel 7
Badge +11

Hi @BVM, sorry to hear of the troubles here! 

I did some digging and found that you’re not the only one who’s been affected by this. We’ve got an existing bug report open for this issue so I’ve gone ahead and added you to it. I can’t give any sort of ETA on when you can expect this to be fixed by. But adding you will help to increase it’s priority and allow us to notify you by email the moment it’s sorted.

In the meantime, do you get email notifications from Eventbrite when someone registers?

If yes, and assuming those emails contain all the necessary registrant details, then as a workaround perhaps you could trigger a Zap from those emails instead. For the trigger you’d need to use an email parsing app like Zapier’s Email Parser. If you’ve not worked with it before I’d recommend checking out out Trigger Zaps from new parsed emails guide for details on how to set it up.

Hope that helps. Do let us know whether you’re able to give that workaround a try and get it working - happy to help if you run into any issues on that! 🙂

Reply