Question

Error status 502 on Sendgrid action 40058

  • 11 June 2024
  • 7 replies
  • 18 views

I’ve setup a simple Zapier

Webflow form (2 fields) to Zapier to Sendgrid (add to contacts of a list)

 

Now it keeps on happening that the step to Sendgrid fails on most (not all) of the new form submissions.

 

I’m on launch day so a lot are coming in and now i’m adding them by hand and trying to fix this in between so all help is welcome! <3

 

 


7 replies

Userlevel 7
Badge +14

Hi @Vera-91 

For us to have context about the error, post screenshots with how the Zap step is configured in EDIT mode along with how the Custom Action is configured.

This post has been edited by a moderator to remove personal information. Please remember that this is a public forum and to remove any sensitive information prior to posting.

Ah, okay is this helping? Also it’s strange because not all entries have an error. 

 

Userlevel 7
Badge +14

@Vera-91 

What about screenshots showing how the Custom Action is configured?

Hi! I don’t seem to have a Custom Action setup. Should I do that in order to have this zap?

Userlevel 7
Badge +14

@Vera-91 

Check the Zap Runs history to see the DATA IN/OUT for each Zap step to help you troubleshoot why some Zap Runs are successful while others are not.

https://zapier.com/app/history/

Check the Troubleshooting and Logs tabs.

 

 

I went into the history and retried the 2nd step and now it worked - strange enough. 

 

The troubleshoot tag says as above.

I did add a custom action by now. Could that help? Or should I add that Zapier should try more often before canceling the zap?

Userlevel 7
Badge +14

@Vera-91 

Try turning ON auto replay: https://help.zapier.com/hc/en-us/articles/8496241726989-Replay-Zap-runs#h_01H9KDDTA16928Y0HE3JVNZF3F

Reply