Question

Error Retrieving Articles from Cointelegraph's RSS Feed: Please Reload Page or Contact Support

  • 25 January 2024
  • 6 replies
  • 146 views

Userlevel 1

Hello community,

I’m trying to create a zap with the following flow:

  1. Fetch new articles from RSS feed. In my case is Cointelegraph’s feed. https://cointelegraph.com/feed
  2. Pass it to ChatGPT to generate title
  3. Pass it to ChatGPT to generate a prompt for image generation with DALE-E
  4. Pass it to chatGPT to write a summary of the article
  5. Take everything from 2,3, and 4 and create a post on WordPress.

The problem I’m facing is I can’t properly fetch the articles from RSS. If I use Cointelegraph’s RSS feed I get this error when I ran the test:

Please reload the page. If the issue persists, troubleshoot error or contact Support.

Error code: Error while retrieving: The app returned "Just a moment...@keyframes lds-ring{0%{transform:rotate(0deg)}to{transform:rotate(360deg)}}*{box-sizing:border-box;margin:0;padding:0}html{line-height:1.15;-webkit-text-size-adjust:100%;color:#313131}...". Just a moment...@keyframes lds-ring{0%{transform:rotate(0deg)}to{transform:rotate(360deg)}}*{box-sizing:border-box;margin:0;padding:0}html{line-height:1.15;-webkit-text-size-adjust:100%;color:#313131}button,html{font-family:system-ui,-apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,"Helvetica Neue",Arial,"Noto Sans",sans-serif,"Apple Color Emoji","Segoe UI Emoji","Segoe UI Symbol","Noto Color Emoji"}@media (prefers-color-scheme:dark){body{background-color:#222;color:#d9d9d9}body a{color:#fff}body a:hover{text-decoration:underline;color:#ee730a}body .lds-ring div{border-color:#999 transparent transparent}body .font-red{color:#b20f03}body .big-button,body .pow-button{background-color:#4693ff;color:#1d1d1d}body #challenge-success-text{background-image:url(data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIzMiIgaGVpZ2h0PSIzMiIgZmlsbD0ibm9uZSIgdmlld0JveD0iMCAwIDI2IDI2Ij48cGF0aCBmaWxsPSIjZDlkOWQ5IiBkPSJNMTMgMGExMyAxMyAwIDEgMCAwIDI2IDEzIDEzIDAgMCAwIDAtMjZtMCAyNGExMSAxMSAwIDEgMSAwLTIyIDExIDExIDAgMCAxIDAgMjIiLz48cGF0aCBmaWxsPSIjZDlkOWQ5IiBkPSJtMTAuOTU1IDE2LjA1NS0zLjk1LTQuMTI1LTEuNDQ1IDEuMzg1IDUuMzcgNS42MSA5LjQ5NS05LjYtMS40Mi0xLjQwNXoiLz48L3N2Zz4)}}body{display:flex;flex-direction:column;min-height:100vh}body.no-js .loading-spinner{visibility:hidden}body.no-js .challenge-running{display:none}body.dark{background-color:#222;color:#d9d9d9}body.dark a{color:#fff}a:hover,body.dark a:hover,body.light a:hover{text-decoration:underline;color:#ee730a}body.dark .lds-ring div{border-color:#999 transparent transparent}body.dark .font-red{color:#b20f03}body.dark .big-button,body.dark .pow-button{background-color:#4693ff;color:#1d1d1d}body.dark #challenge-success-text{background-image:url(data:image/svg+xml;base64……………

 

If I create a feed with RSS.app I can fetch the articles and when I run the test for the whole flow a new article is posted on my WordPress website, but when I turn on the Zap nothing happens. New articles keep showing in my RSS.app feed but they are not posted on my website. When I hir “Run Zap” I got a message saying there is now need items in the feed, but there are.

 

Any ideas how I can resolve it?

Thanks!


6 replies

Userlevel 7
Badge +6

Hi there @CheekyCrypto,

Welcome to the Community! 🎉

From what you've mentioned, it seems you're encountering an error when trying to set up your RSS feed in Zapier. The error message indicates that there might be an issue with JavaScript and cookies on the RSS feed site.

Here's what you can try to resolve the issue:

  1. Check if JavaScript and cookies are enabled in your browser settings. If not, please enable them and try setting up the RSS feed again.
  2. If you're using any browser extensions that might interfere with JavaScript or cookies, try disabling them temporarily and see if the issue persists.
  3. Please clear your browser's cache and cookies, then try to set up the RSS feed again.
  4. If possible, test setting up the RSS feed on a different browser or device to see if the issue is specific to your current browser.

Could you please give that a try, and let me know how it goes? 

Userlevel 1

Ok, let me try that and get back to you.

 

Thank you for your reply!

Userlevel 1

Hi there @CheekyCrypto,

Welcome to the Community! 🎉

From what you've mentioned, it seems you're encountering an error when trying to set up your RSS feed in Zapier. The error message indicates that there might be an issue with JavaScript and cookies on the RSS feed site.

Here's what you can try to resolve the issue:

  1. Check if JavaScript and cookies are enabled in your browser settings. If not, please enable them and try setting up the RSS feed again.
  2. If you're using any browser extensions that might interfere with JavaScript or cookies, try disabling them temporarily and see if the issue persists.
  3. Please clear your browser's cache and cookies, then try to set up the RSS feed again.
  4. If possible, test setting up the RSS feed on a different browser or device to see if the issue is specific to your current browser.

Could you please give that a try, and let me know how it goes? 



Hello again!

I think the problem persists. Here is what I did:

1. I used a different browser.
2. I cleared the cache of that browser.
3. The cookies and the JS are enabled.

When I test the last step where I should post and article on my WordPress website it’s actually working.

Right after I tried to “Run Zap” the response was that no new items were found.

Userlevel 1

I think I fixed it. I will keep an eye on it in the next 1-2 days.

Userlevel 1

I think I fixed it. I will keep an eye on it in the next 1-2 days.

How did you fix it? What did you do?

Badge

I think I fixed it. I will keep an eye on it in the next 1-2 days.

How did you fix it? What did you do?

Most typical internet tech support thread ever.

Reply