Question

Elementor form (WordPress) - single-option fields not showing values, only IDs

  • 13 February 2024
  • 1 reply
  • 12 views

I’m having exactly the same issue but from an Elementor form (WordPress) to Pipedrive through Zapier.

I created a single-option custom field with “Success” and “Failed” as options but when I try to send the value from the webiste form field, that has one of these values (or empty), it always gives the same error, that’s expecting a number. However, the custom field has text values and I confirmed it on the page code, it clearly says input type="text".

Really hoping there’s a solution for this...


1 reply

Userlevel 7
Badge +11

Hey there @PedroBranco. Thanks for joining the Community here! 😁

Hope you don’t mind but I’ve moved your post out into a new topic so we can address it here separately.

For fields like that where you’re dynamically selecting the value for it will be expecting to receive the ID number for the option. The ID number usually appears just under the name of the option when you click into the field to see the available options. You can see an example of what I mean here:
da838bc8b4381e1b0ca186defa8e15c3.png

As that field is only appearing as a text field with no list of options to select then I’d recommend taking a look at the setup of the field within Pipedrive to see if you can identify the ID numbers for the “Success” and “Failed” options.

Then, in order to pass the relevant ID for the option I’d suggest using a lookup table to convert the value that you get from the Elementor form into the corresponding ID for the option that needs to be selected. You can learn more about to set up lookup tables here: Create lookup tables in Zaps

Can you give that approach a try and let us know how you get on?

Reply