Cannot remove "Zapier for Gmail" add-on and can't seem to find proper solution

Userlevel 1

Greetings, dear Zapier community,


Since I have been absolutely frustrated playing around with removing a small Add-On, being referred to Zapier Support by asking Google support, and vice versa by reading community posts thoroughly, I felt I need to ask ultimately to make sure whether the community experts are able to help me and probably others out to fix the issue, or this is just wasting my time since nobody might know how to remove the unnecessary add-on whilst developing and monetizing it.

Therefore, I would be undoubtedly appreciative to those who could offer a REAL solution except referring to unsolved threads.


To specify, I used to be a Google One user (probably this might help regarding the perks it brings), but since I have moved to iOS I found it unnecessary for the time being to pay two cloud subscriptions. The time I was Google One user, I downloaded Zapier to give t a try, which I never actually have. Although it might be a great concept, I just haven’t noticed its usage in my own daily tasks. That’s why I ignored it till I have cancelled the Google One subscription too.


The issue I’m facing is EXACTLY the same as reported in this post, left unsolved, yet referred to by a support agent, when I wrote them an Email.


All methods that I have tried, although none of which has worked:

  • changing web browser
  • clearing cache, even cookies just in case
  • trying to remove Zapier permissions in Google Account Settings (it’s not listed there)
  • Removing Zapier from Marketplace installed Apps (it’s not listed there)
  • Reinstalling and then trying to remove the add-on (successful install, failure upon uninstalling, since the icon is still there..)
  • Disabling browser extensions
  • Updating browser (although this is super annoying for a user who thinks of automating his tasks to get suggested to “update” his browser, while for most of the people it does update automatically even if they don’t know the basics)
  • Contacting Google support (referred to Zapier support, which makes sense)


The Issue if exactly the same as mentioned in the post I linked above, and I’m not wiling to sign up to use the service, nor planing to pay for such in the near future, nor intending to, since such a small problem seems not to be fixable.




11 replies

Userlevel 3
Badge +2

@schak  I totally understand your frustration.

But have some recommendations for you if you can try them out


  1. Check for Multiple Accounts: Ensure that you are not logged into multiple Google accounts in the same browser. This can sometimes cause conflicts, as changes might be getting applied to a different account than intended.

  2. Incognito/Private Browsing Mode: Try to remove the add-on using your browser's incognito or private browsing mode. This mode disables most extensions and uses a fresh session, which can help bypass issues caused by session data or extensions.

  3. Try a Different Device: Sometimes, issues can be device-specific. If possible, try to access your Gmail settings from a completely different device and attempt to remove the add-on.

Userlevel 1

Dear @communitymember ,


Thank you for your quick response, and I appreciate the tips you have mentioned.


Unfortunately, that didn’t fix the problem, since the app icon and therefore the add-on exists even on another device, another browser and in Private Mode of the browsers I have tested on, neither with nor without extensions activated.

The only account I have Gmail-Web on is the one i faced the problem with, since I never installed the add-on on another account’s marketplace.


I’m looking forward to hearing back from you, as well as people, who were able to fix the issue.



Userlevel 3
Badge +2

@schak what response did you got from Zapier support and Google Support.

Userlevel 1

Dear @communitymember ,


Following is the response I got from Google Support, and below is the translation.



“Thank you for reaching out to the Google Support team.

I understand that you have concerns regarding the deletion of the Zapier add-on in Google Web. Let's work together to guide you to the right resources.

It's best to reach out to Zapier directly with your concern, as our team can only provide general support for this issue.

For further information and self-help options, please refer to the Google Help.

We hope we were able to assist you.”

Userlevel 7
Badge +11

Hi there, @schak! 👋

I’m so sorry about all the trouble you’ve experienced in trying to get this sorted. There was another thread in Community discussing how to uninstall it here:

I shared some instructions I’d found in that other thread which you may want to give a try, but I should note that for the other Community member they didn’t work and they had to reach out to Google’s support team. I’ll share those instructions below in case you wanted to give them a try to see if they work for you.

Here’s the first:

I did some digging online and it found a thread on Gmail’s website where there were a few different ways suggested in which folks were able to uninstall a Gmail add-on:

One of which was to try the following:

  1. In Gmail, click the Settings icon in the top right, and click Get add-on from the drop-down menu that appears.
  2. A pop-up box will appear with the Works with Gmail apps.  Click the 3 horizontal lines in the top left to get the menu. Scroll down to the bottom of the menu and click Manage Apps.
  3. Your installed Add-On should be listed. DON'T click on it! Instead, click the 3 vertical dots next to the Add-On's name, then click Remove from the drop-down menu.
  4. Wait for the pop-up confirmation screen, and click Remove app.

And here’s the second:

I’ve been trying to hunt down some alternative solutions for this and could only find the following instructions on how to Remove a third party’s access in Google’s help documentation:

  1. Make sure you’re signed in to your Google Account.
  2. View the apps & services that have access to your Google Account.
  3. Select the app or service whose access you want to remove.
  4. Under “{App name} has some access to your Google Account,” select See details.
  5. Select Remove access.

It’s a bit of a long shot, but I’m hoping that might allow you to see the Zapier add-on’s connection to your Gmail account and force it to remove the add-on that way.

If those don’t work then it would be necessary to reach out to Google again to ask if they can remove the app from your account. The Zapier add-on for Gmail was deprecated on 09/08/2021 and removed from the Google Marketplace (see the note at the top of this blog post). Unfortunately there’s nothing we can do on our end to remove it from your account, only Google would potentially be able to take that sort of action.

Please do give the above suggestions a try and keep us updated on how you get on. Would love to hear from you on this!

Userlevel 1

Dear @SamB,


I appreciate your suggestions on this issue. Unfortunately, I haven’t succeeded to remove the add-on using these methods, as they seem to be the only ways being suggested for this issue.

I would appreciate it if I could get a proper contact info of Google support, where I wouldn’t get the above answer.

Below are the screenshots indicating the failure of conducting these two methods:

The add-on icon is visible on the right bar/panel, although it’s not visible on the List of installed apps.


The add-on seem not to be listed in the apps and services, which has access to my account
Userlevel 3
Badge +2

@schak is this resolved or still on your way

Userlevel 1

Dear @communitymember ,


It’s not resolved, unfortunately! The suggested method was already tested and didn’t work out.

Userlevel 7
Badge +11

Thanks for giving those a try @schak, I’m sorry to hear they didn’t work for you either.  

I don’t have a direct contact point for Google’s Support team unfortunately. If their Support team isn’t able to assist then it might be worth reaching out in Google’s Gmail Community about this:

Hopefully someone in the Community on their end will be able to advise how to remove the add-on from Gmail. 🤞

Do keep us updated on how you get on, would love to hear whether you’re able to get a solution on this!

Userlevel 1

@schak I feel your pain. I have gone through the same circular support experience as you. I read all the threads, contacted both google and zapier support and tried every proposed solution. 


Still have not solved but here is what I have found so far:


The issue seems to be an artifact left over from the original add-on. It is saved within the application data which is why it appears on different browsers and after deleting cache. I was able to locate the icon image using developer tools under:


Application > Frames > top > image > Esy1tWUboGsR6Wa3mg-E61LOGASKZjSDcYpDMg9IhuY2FPLjsX-lGWZmM_9qV_bJPG0V4VeNY2Ud4le4lIlkDLfIvF_lAOf58xDv88U=s48


There is probably more data to remove, but I am not experienced enough with the internal workings of Gmail to be confident fiddling around and deleting data. However, I suspect that this is the only viable solution. 


@SamB I kindly request that the Zapier support team (since you are the original developers of the add-on) get a team developer to advise on how to safely remove this artifact.



Userlevel 7
Badge +11

Sorry to hear that you’re running into this trouble as well @MilesB!

I think Google would be better placed to advise on how best to remove any lingering add-on data from Gmail. But I’ll reach out internally to ask that someone from our side gets in touch with Google to see what else can be done to remove the Zapier add-on for Gmail. I can’t make any promises but I’ll be sure to share any updates we have in the thread here. 🙂