Best answer

Can't post photos from Jotform to Tumblr

  • 27 June 2023
  • 5 replies

Userlevel 1

I have created a Zap that is triggered by the submission of a form via my Jotform account, and it’s intended to take the submitted photo(s) from the Jotform and post them to my Tumblr blog. I’ve verified the connection of both accounts, identified the fields containing the photo(s) and name of the person submitting the form, and a tag to be included with the post. But when I run a Test, the app returns “Bad Request” and I get the message “No data was found.”

I’ve tried skipping the test and publishing the Zap anyway, but it still errors out. 

I’ve tried removing the name of the submitter and the tag, but it also still fails. 






Best answer by Troy Tessalone 27 June 2023, 22:29

View original

5 replies

Userlevel 7
Badge +9

Hey there, @CharlieZ! Thanks for reaching out in community - I’m sorry to hear you’re running into this and definitely want to help.

Hmm, before we jump in is it possible to confirm Zapier has read/write access to the Tumblr account? More on that here

One thing that may also be worth checking is if HIPAA compliant forms are enabled on Jotform. If so, protected fields won’t be sent to Zapier (these fields will appear blank) to remain compliant. Here’s another similar question that walks through how to fix this:

If neither of those apply if you don’t mind sending us a screenshot of both the trigger and action setups, with any personal details removed. Sometimes those visuals can help the community troubleshoot with you. 🙂

This is an example from a different app but shows what we’re looking for in those screenshots.

Keep us posted! 🙂

Userlevel 1

Thanks for the quick response!


  1. I granted Zapier access to my Tumblr account. I tested that again and confirmed it.
  2. My Jotform account is not HIPPA compliant/restricted. (Shown in attached PDF)
  3. The attached PDF shows my trigger and action setups.

Looking forward to any insights - even if it means I missed something simple! 


Userlevel 7
Badge +14


Good question.

You likely need to change the Jotform account settings.

Settings > Security > Privacy > Require log-in to view uploaded files (uncheck)


Userlevel 1

Ineeed - that was part of it! 

Also, I discovered that Zapier can only post one photo at a time to Tumblr - and the same with Twitter.


Problem(s) solved - thanks!!

Userlevel 7
Badge +6

Hi @CharlieZ,

Cool! We’re glad to hear everything is now sorted out!

If you have any other questions, please don’t hesitate to post in the Community. We’re always happy to help! 😊