Best answer

Can't load area paths to set up Azure Integration

  • 20 December 2022
  • 5 replies
  • 98 views

I am attempting to connect AirTable with Azure, using Zapier.

While setting up my Zapier integration with Azure, I am receiving the following error when trying to build a new Zap:

“Unable to load choices
We're having trouble loading 'Area Path' data. Required field "Project" (project) is missing.”

Area paths represent directories where work is stored in Azure.

Without the ability to load and select area paths from Azure, I cannot create the connections I need to set up Create/Update work triggers from Azure to Zapier.

 

How can I get Zapier to load my Azure area paths so that I can complete my integration?

 

Thanks!

 

icon

Best answer by nicksimard 21 December 2022, 18:47

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi @aMastermind 

 

Are you sure the account you are connecting to Zapier has the correct permissions? 

 

If it does, you might wanna open a ticket with Support for this. https://help.zapier.com/hc/en-us

Userlevel 7
Badge +9

Hey @aMastermind! It could be helpful to see how your Azure step is configured as well. Sometimes old data gets caught in there and causes some issues. Just be sure to not share any personally-identifiable information when sharing. Looking forward to helping work through this one with you!

Thanks Jesse,

Here is a screenshot for 3rd step of the Azure <> Zapier integration that I am trying to set up:

Please note that I tried setting the Azure account URL to go directly to a project address (dev.azure.com/companyname/projectname), but was unable to connect to the project directory, and instead had to connect to the general dev.azure.com/companyname directory.

At no point was I asked to select a “Project” within my Azure account, so I had no opportunity to give the trigger the correct “Project” field so that it could find the required area paths to set up the integration.

I’m not sure how to designate the correct project within my company’s account and am blocked here until I can resolve this.

 

For the first two steps I chose:

1.) “Create work item” from “Azure DevOps”

and

2.) Insert company Azure URL slug > dev.azure.com/companyname

 

Userlevel 7
Badge +11

Hey @aMastermind!

I remember seeing something like this in the past. Can you try selecting the Project first (which shows up below Area Path and Work Item Type):

 

Then see if you’re able to get the other fields above working. Can you give that a shot?

Thanks @nicksimard!

 

That did the trick. Apologies for that not being obvious for me to try previously.

 

I might recommend changing the order of the setup fields to Project > Area Path > Work Item Type for other dummies like me who may ask again later. 😅

 

Cordially,

Norval