Best answer

Can I force my Zap to refresh and choose the last three payments in Stripe?

  • 29 November 2022
  • 5 replies
  • 286 views

Userlevel 1

Hi all,

 

I’m trying to configure a Zap with Stripe as a trigger (new payment), but in order to test, i click on load more data to test the trigger and it always loads the same 3 payments, even if they were not the last 3 to begin with, and some more payments came in afterwards and it still pulls the same 3 it’s incredible.

Even if I wait,  I click again on. “load more data” it says more data found, and then, instead of having A,B,C, i now have A,B,C,D,E,F but they are the same 3 repeated 2 times!

So how can I force the Zap to refresh and chose the really last 3? I tried creating another zap, reconnecting the Stripe and it stays the same :))

I need this because I changed the metadata I’m sending to stripe and that happened after the 3 payments it’s pulling me so i’m unable to test with the new data structure.

Thank you for your help :)

icon

Best answer by christina.d 1 December 2022, 11:10

View original

5 replies

Userlevel 7
Badge +14

Hi @djamk 

Good question.

You should probably open a ticket with Zapier Support to report what could be a bug: https://zapier.com/app/get-help

 

1 option to use as a workaround...

 

Stripe Webhooks: https://dashboard.stripe.com/webhooks

Zap trigger will be: Webhook - Catch Hook

This will generate the webhook URL to use in the Stripe Webhook setup.

Userlevel 1

Interesting @Troy Tessalone thanks a lot for your answer, i will dig further with the webhook alternative and I'll write to support and see.

 

Still if anyone had the same problem before I'd love to hear about it!

Thanks a lot,

D.

Userlevel 7
Badge +9

Hey friends, I wanted to pop in and confirm some of the insight shared from the ticket!

It looks like this was confirmed to be a bug with the “New Payment” trigger in Stripe. 😔 Specifically:

Stripe isn't pulling in expected samples, and often gets stuck on the same one or two samples.
 
There's a bug report in place, and I've added your contact information to it. At the moment, a workaround isn't available, but we'll get back to you right away when a fix ships for the problem.

We’ll also be sure to update this topic as well once a fix is in place! Sorry to not have better news here but definitely appreciate you flagging this in community.

One thing to note is that this is an issue with pulling in the expected samples when you test the trigger in the Zap editor. When the Zap is turned on, the correct information will come in from Stripe. If you can, try to set up your Zap using the dummy sample fields and then you’ll be able to turn it on. If you have trouble with this because there’s no data in a field in the test data, reach out to the Support Team using the Get Help form who can work with you to try and get your Zap set up. 

Userlevel 1

I struggled with the webhook idea (but apprecaited the idea), so hoping there is a fix for this bug soon. Thank you.

If payment gateway could not support then can I past thete the payment link!

Reply