Best answer

Bubble app deployed and Zapier doesn't work

  • 5 January 2022
  • 11 replies
  • 438 views

Userlevel 1

I created 3 zaps for my bubble app on the development to send Bubble data to Airtable and to send notifications to my slack. They were tested and worked seamlessly.

Now, I deployed the bubble app and Zaps are not working.  My understanding was that once Bubble is deployed, zaps are automatically converted.  In SET UP TRIGGER, I only see Development in App version field, no LIVE. 

Am I missing anything here?

Thank you.

icon

Best answer by SamB 11 March 2022, 13:49

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

11 replies

Userlevel 7
Badge +14

Hi @johnrhee 

Some options to troubleshoot…

 

Do I need a personal Bubble plan or higher to use Bubble with Zapier?

You need a paid Bubble plan to use Bubble with Zapier.

 

Check the help article for Bubble: https://zapier.com/help/doc/how-to-get-started-with-bubble-on-zapier

 

Make sure your Zap is ON.

 

Check your Zap Runs after testing live: https://zapier.com/app/history/

 

Search the Zapier Community for related Topics: https://community.zapier.com/search?q=bubble

 

Open a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 1

Hi Troy,

Thanks for options.  ZAPs are ON, I am on a paid plan, tests work fine but in development version, not LIVE version though. 

I opened a ticket for support. 

Still, not working… ^^

Thanks anyway.

John

Userlevel 7
Badge +14

@johnrhee 

Try reconfiguring the Zap trigger now that the Bubble app has been pushed live.

Userlevel 1

Hi, again.

That’s my question. I also tried to refigure the zaps.  But, the problem is there is only Development version in the app version field - NO LIVE version. That’s where I am stuck. :sob:

Userlevel 7
Badge +14

@johnrhee 

Perhaps you need to reauthenticate the Zap app connection here for the live version of your Bubble app: https://zapier.com/app/connections

Hi @Troy Tessalone,

I am having exactly the same issue. Bubble app was pushed to live with the zap turned ON (and successfully tested in development) but it does not really work in live mode. I have followed all your suggestions, including reauth the Zap app.

 

What is weird is that only in the “New Workflow Trigger Event in Bubble” the Live version is not available. In the last action of the workflow, which is “Modify Thing in Bubble”, the live version is detected and can be selected.

 

How can we have someone from Zapier taking a look into it ?

 

Thanks

 

 

 

Userlevel 7
Badge +10

Hey @OutlierZ!

It seems @johnrhee reached out to Support previously and the issue was caused by the Live version missing a Zap trigger in the workflow.

If that’s not the case for you as well, I’d recommend reaching out to our Support team also. They’ll be able to take a look at the logs for your Zaps and can investigate things further. The best way to reach them is via the Get Help form. 

Please do keep us in the loop on how you get on! :)

Hi @johnrhee were you able to make any progress here? I am having the same issue 

Userlevel 7
Badge +9

Hiya @mfranko33! Thanks for reaching out. It might be worth reaching out to our Support team to see if they can dig into this for you! 🙂

It seems @johnrhee reached out to Support previously and the issue was caused by the Live version missing a Zap trigger in the workflow.

If that’s not the case for you as well, I’d recommend reaching out to our Support team also. They’ll be able to take a look at the logs for your Zaps and can investigate things further. 

 

Any headway on this? I’m experiencing the same problem - paid Bubble app is deployed live, the Live version has a Zap trigger in the workflow, testing worked fine, but I have no option to select an app version other than Development with Zapier.

Userlevel 7
Badge +10

Hi @Flip, thanks for checking in here! 

I did some further digging on this and it seems that sometimes it’s possible to select the Live version by selecting it as a Custom value. To do that you’d need to click on the Custom option then manually type in live into the App Version field.

For example: 
a87c4daf2c58d763cca2fcd9f9bebf61.png

Can you give that a try and let me know if that does the trick?