Best answer

Affinity error: Failed to create a person or organization field value in Affinity - Got 422 calling POST https://api.affinity.co/field-value, expected 2xx.

  • 24 May 2022
  • 4 replies
  • 315 views

Userlevel 1
Badge

Hello,

I am integrating Eventbrite and Affinity.

Once the person gets a ticket in Eventbrite, I want to update the status of this person in a specifc list. the new status should be: Accepted TICKET REGISTERED.

 

 

Unf. I am having troubles when updating the status at the test: 

 

This is the zap: https://zapier.com/editor/122923315/draft/122924089/sample

icon

Best answer by jesse 1 June 2022, 20:58

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @Michael_CalmStorm 

Please post more screenshots with how your Zap steps are configured in order for us to have full context, thanks.

 

Fore example, make sure to remove the Extra Fields, which could be contributing to the error/issue.

 

Userlevel 1
Badge

I manage to find the person, the entry list, but I can’t change the status. This status already exists in Affinity.

The extra field you mentioned, was this status that I am trying to change.

Can you help me with this?

Thank you!

Userlevel 7
Badge +9

Hey @Michael_CalmStorm Hmm, from what I am seeing, you’re doing the right thing. I am wondering if this is some kind of bug. Because of that, I’d recommend taking this one to support: https://zapier.com/app/get-help

I know I’ve directed you there a few times now but due to the nature of your issue, I believe this will be the fastest way to troubleshoot and get you a resolution! Thank you SO much for your patience and willingness to work through this with us. You’re in good hands. 💖

Userlevel 7
Badge +9

Hey @Michael_CalmStorm! Just circling back to close the loop on this thread for you and anyone else following along. Our support team asked you to try publishing the Zap, then submit a new Eventbrite registration so that the Zap gets triggered, which looks to have helped get you back up and running!

For anyone experiencing a similar issue, if the field still does not get updated, contact our support team and give them permission to test the Update an Entity in Affinity action in your Zap. From there, they can pull up specific logs to help locate why the update isn’t happening.