Best answer

403 Forbidden Wordpress Media Upload

  • 7 September 2023
  • 1 reply

Userlevel 1
Badge +1


After trying EVERYTHING I noticed there was a secondary action called “wordpress Legacy”.

I replaced the current modern “wordpress action” and boom, it worked.

Unsure why the legacy version would work vs the newer version but… It works with this setup.

All day I've been trying to upload media to wordpress website through an upload media to wordpress action.

I do not have any security plugins, my hosting provider is not blocking access and zapiers IP's are whitelisted. I've deactivated all my plugins including security, changed image format, created a new user and tried connecting - nothing is working :/

For the life of me I cannot figure out the problem.

The workflow is:

Dropbox → Wordpress

I can create posts with no issues.

It's just when I upload media causing the issue. I connected another wordpress site and uploading the same media works but its just this website that it wont upload to.


Is any dev team able to help at all?


Best answer by SamB 7 September 2023, 15:58

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +11

That’s great news @Englander! I’m so pleased you were able to get this solved by switching to the Legacy version of the WordPress app. The code is different between the two apps so that’s likely why the error is only effecting one of the apps.

There is another topic in Community discussing the bug that’s causing the same error you were getting previously:

I’d recommend subscribing to that topic so that you’ll be notified when it’s resolved as we can’t guarantee how long the Legacy version will be available for. Then you can switch back over to the newer version of the WordPress app once the bug has been fixed.

Since we’ve already got one topic relating to that “403 Forbidden” error I’m going to close this one out. For anyone who comes across this and wants to be added to the bug report please reach out on the main topic and we’ll be sure to add your details to it.