Quirk With Google Sheets Trigger Testing

  • 21 January 2020
  • 2 replies

Userlevel 4

I just spent the last few hours trying to figure out why updating a cell in a row using a formula did not appear to be triggering my Zap.

If you manually update data in a row, the Find Data function in the editor will work just fine.

However, if a formula is changing the data in a row, then the Find Data function will not return any data. It just times out after 3 minutes with the "We had trouble finding a sample." error message.

At first, I thought it was some kind of limitation with Google Sheets or Zapier. Maybe you couldn't use formulas to trigger your Zap. But that did not make a lot of sense. Several searches did not turn up any information one way or the other.

Finally, I tried testing the Zap live. And it worked!

Bottom line:

If your Sheet is using a formula to update data in a row, and if you are trying to get sample data, it will not work! You have to test by enabling your zap.

Not sure if this is a bug or intentionally designed that way, but it sure had me running around in circles for several hours trying to figure out why my zap would not trigger and return sample data when the content in a row was changed with a spreadsheet formula.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +12

Thanks for sharing this @RonW!

It's not really a bug or an intentional feature - it's more a side effect of how information is passed from Google Sheets. I'm sorry that it caused you so much hassle trying to figure it out!

Userlevel 7
Badge +10

@RonW - good to know! Thanks for sharing.