Zoom New Recording trigger now downloads files

Categories: App Integrations
Zoom New Recording trigger now downloads files

Hi everybody, Scott here from the Engineering team. I’m really excited to tell you that as of today the New Recording trigger on the Zoom integration allows you to download files to other services!

For now this only works on recordings that are not password-projected, so go to your Zoom recording settings page here and make sure the “Only authenticated users can view cloud recordings” and “Require password to access shared cloud recordings” settings are turned off.

 

The fields for the download URLs all end in “dl_urls” (e.g., audio_dl_urls, video_dl_urls).

 

These are line items fields, so if you stop and re-start recording during a meeting, they’ll behave like line items. If you only have one recording per meeting, though, they should work just like any other field.

Furthermore, this will only work for new recordings, i.e., those recorded after the Zoom settings above were set to “off.”

In anticipation of some users requiring this to work for password-protected recordings, we’ve added Feature Request #111 to Zoom.

As always, let us know if you have any questions or feedback!

Hi @rolodexter!

I see that you’re trying to send a zipped folder to YouTube, so that’s not going to work:

Do you have any data fields coming from Zoom that are not zipped?


i’m having the same issue i can’t find the trigger that

Hi @rolodexter!

I see that you’re trying to send a zipped folder to YouTube, so that’s not going to work:

Do you have any data fields coming from Zoom that are not zipped?

 

I'm having the same problem I can't find the zoom trigger that automatically selects the MP4 file for upload it always extracts only zip files and TXT files

and the zip files that ZAP finds isn't even a zip of all the MP fours it's just a zip of text files that reference that packages all of the URLs that can be clicked on to get to the files that i need

 

i need a trigger paramater that gets the mp4 directly 


The thing that I've resorted to is just doing manual downloads to a cloud folder and then syncing the cloud folder to YouTube once I know that a folder has been segregated to MP4 only


Hi @PediaHealth Support!

As mentioned in the original post, you have to make sure of a few things:

  1. “Only authenticated users can view cloud recordings” is turned off
  2. “Require password to access shared cloud recordings” is turned off
  3. That you map the video fields shown here, that end with _dl_urls:

    So something like share_url or video_play_urls or Recording Files Download URL won’t work.


@nicksimard We have had the suggestions above toggled off for several months, but the only time the test Zap works is if we go to an individual recording and toggle “Viewers can download” on (see image below). The zap will have triggered by the time this option is changed (Zoom doesn’t currently have a default selection for all videos). Do you have any suggestions?

 

 


Hi, 

Does somebody tried to upload a zoom recording into One drive (Microsoft)?

I tried to upload it to Google Drive and it worked perfectly, but when I want to send the video to one drive, I can see it, but I can’t open it. 


Hi @TTLT!

Do you mean that you’ve had these options turned off…

… and even when your Zap is turned on, it doesn’t trigger properly? 

@Fitzap I don’t see a reason why it wouldn’t work for OneDrive. So are you saying the file itself gets uploaded to OneDrive but you aren’t able to then play it? Maybe it needs a file extension, assuming that’s not already present?


I too am stuck. I followed the instructions on the youtube video - 

I read the above advice. I don’t know what “That you map the video fields shown here, that end with _dl_urls”

I just took the preset settings from zapier for both zoom and youtube. The test for zoom works. The test for youtube - does not. The settings in youtube are auto generated by zapier

But when I test - nothing happens. As advised I removed chat and audio download but it still did not work. I set up the recordings settings so that it should be password free but that didn’t work. 

Any advice would be helpful

thanks


just to clarify the error that I am receiving - 

The app returned "Media type 'text/html;charset=utf-8' is not supported.".

And the goal is that every day the video that is recorded will be automatically uploaded to youtube

thanks - here is a printscreen of the test

 


Failed after read all “help” stuffs and trying it for 2 hours.

Only html in my Drive no mp4.

It is not easy at all to make it works. Removed zap. Move on.

 

 


Hey @Daf and @nyzkostd,

Sorry about all the troubles with uploading your Zoom recordings, that’s not what we want at all! I did some digging and it looks as though a similar issue was discussed and answered in this thread:


There’s a couple of potential solutions suggested in that thread which may be worth giving a try to see if that solves things. Hope that helps! :)


Thank you so much guys! This is exactly what I wanted. 

Files were getting saved as htmls but we removed the file extension setting from Zap and now it works, only videos are getting uploaded. 


Hey @Daf and @nyzkostd,

Sorry about all the troubles with uploading your Zoom recordings, that’s not what we want at all! I did some digging and it looks as though a similar issue was discussed and answered in this thread:


There’s a couple of potential solutions suggested in that thread which may be worth giving a try to see if that solves things. Hope that helps! :)

Hi SamB, thank your for the link.

I have tried again and again, still no avail.

I tried spl***.io and it worked on the very first try. Only 2-3 clicks.

Sorry, I think Zap needs solved this problem to make it works and user friendly.


Hey @nyzkostd!

Thanks for giving those suggestions a try, I’m sorry to hear they didn’t work as hoped.

I think your next best bet will be to contact our Support team using the Get Help form. They’ll be able to dig into the logs and set up of your Zaps to investigate further!