Best answer

Zaps triggering on private YouTube videos

  • 15 March 2023
  • 7 replies
  • 35 views

Userlevel 1

I made a zap to post to LinkedIn whenever I post a new YouTube video to a certain playlist.  Sadly, it posted a bunch of still-in-process videos that I added to the playlist, but were set to private.  That doesn’t seem like the desired behavior!  Please advise me on how to correct.

icon

Best answer by ken.a 17 March 2023, 00:24

View original

7 replies

Userlevel 7
Badge +14

Hi @SmartCarrion 

Good question.

In order for us to have enough context, please post detailed screenshots with how your Zap steps are configured, thanks.

Userlevel 2
Badge +1

Hi @SmartCarrion 

Hopping in for this thread. You mentioned videos were posted but were set to private. Was it set to private on LinkedIn?

Userlevel 1

Here is when I added 3 private videos to a playlist, and it instantly ran the zap:

The LinkedIn part worked just fine really, it just shouldn’t have been triggered by the YouTube part, so i’ll post that configuration (its very basic and simple to recreate):

I was just posting a link to it on LinkedIn, not the actual video. So it posts the link with the title and picture and everything, but if you click it and go to YouTube, there is no video (since it is private).  I also didn’t have the final thumbnail, description, and title since the video wasn’t supposed to be published yet!

 

 

Userlevel 1

My use case is I’m scheduling a bunch of clips to post over the week using YouTube’s “schedule” feature, and i was hoping to have Zapier make social media announcements when the clips go live.

Userlevel 1
Badge +2

Hey @SmartCarrion,

I did some digging into this, and it seems like we’re running into a bug here. Our team is aware of the issue and we're working with YouTube on a fix. I've added your vote as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  •  Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

Userlevel 1

Thanks for the work on it!  I noticed the meta data available in the zap did not include the publish status or go live date or anything like that.  I’m guessing that’s because it isn’t coming to you through the YouTube API.  Good luck getting it worked out! 

Honestly it is surprising that they list private videos in the playlist at all.  That has me thinking, is there a workaround to pull the playlist with a different account that does not have access to the private videos?  Maybe then then playlist would only show the public ones?

Userlevel 7
Badge +11

That’s a great idea for a workaround here, @SmartCarrion! That could well exclude the private videos from triggering the Zap if the other account doesn’t have access to them.

Are you planning to make those currently private videos public at a later date though? Asking as I’m not sure whether the Zap would then be able to trigger on them.

I’m thinking that if they’re already added to the playlist then the New Video in Playlist trigger might ignore them if it considers the existing publish dates to be too far in the past. So you might need to remove the video from the playlist make it public, then add the video back into the playlist to get it to trigger the Zap. I’m hoping that might help to get the Zap to regard it as a new video and allow you to trigger the Zap on it later.

If you do implement that workaround please do keep us updated on how it goes! 🙂

Reply