Best answer

Zapier Not Pulling The Data I Need From Stripe

  • 20 March 2021
  • 6 replies
  • 1596 views

Hi, I have tested a payment in Clickfunnels test mode. This payment is registered as successful in Stripe. But is not being picked up via Zapier so I'm unable to build out the rest of my Zap. Does anyone know why this is or what I am doing wrong. I can not purchase the product out of test mode as it is an expensive product. Thanks

icon

Best answer by Troy Tessalone 21 March 2021, 04:39

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @Hi_its_J 

Try adding a promo code for $0 that can be used to test transactions in live mode.

 

No Data - All Payments/Customers/etc. Missing

Usually this is because a "test" key is used to connect Zapier to Stripe and payments/customers/etc. are created on the "live" account (or vice versa).
The solution is to make sure to use the correct key!

 

Stripe Test Mode

We use Stripe API keys for authentication, so you can connect a Stripe account by using your Stripe "test secret key".

If you do that, you can trigger your Zap from transactions in your Stripe account which were created in test mode. Stripe's test card numbers only work in their test mode:
https://stripe.com/docs/testing#cards

However, if you connect to Stripe using the test secret key, your Zap will not trigger on any Live transactions in your Stripe account.
To do that, you'd need to reconnect, or connect a new Stripe account, using your "live secret key" instead.

 

Hi @Troy Tessalone this was extremely helpful. Do you know whether once I have pulled in the test data using the Zapier test mode and then use the data fields from this test to set up the rest of the zap, will the same fields work once I switch back to the live mode keys?

 

 

Userlevel 7
Badge +14

@Hi_its_J 

The same fields “should” come thru for live vs test mode, but you’ll have to check to verify.

Best advice: When in doubt, test it out.

@Troy Tessalone thanks once again. I did try it out but, what has thrown me is that when I choose my live stripe account and then look through the Zap the filter that I set up looses the metadata I believe it needs to identify the actual payment I want to trigger the enrollment into Teachable. 

and I have not tested it out in the live environment, as explained, as it a large amount. 

 

Any thoughts on a way around it or an article that could show me how to do your suggestion if possible.

 

Thanks  

Userlevel 7
Badge +14

@Hi_its_J 

Here’s an article about copying Zaps: https://zapier.com/blog/how-to-copy-or-clone-zaps/

Userlevel 7
Badge +14

@Hi_its_J 

Try this trick as well to get the desired metadata: Add Stripe Find Charge as Step 2 in the Zap.