Best answer

Zapier does not detect google form spread sheet

  • 12 February 2021
  • 4 replies

Hello everyone!


I’m having difficulty when I attempt to connect google forms to something. It won’t find my spreadsheet. I’ve tried this both on my normal account and made  a new google account and Zapier will not find my newly created spreadsheets. Is there any way to fix this? It completely eliminates integrations with Google forms… 


Thank you,



Best answer by GetUWired 12 February 2021, 15:01

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +10

Hi @DanAdrian 

When you say it doesn’t find it, what do you mean?

Can you show us some screenshots of what you’re seeing?

Of course. I’ve attached two images, one with what I see in Zapier, and one with my drive, which shows there is a form created. This is the same in my main account, where there is a large list of other things in my drive, but not the google form I created. I’ve tried searching and clicking Load More in my main account. 

Userlevel 7
Badge +12

Hi @DanAdrian 

Google forms need a saved destination, please follow the instructions here

Thank you! That worked.