Best answer

Zap works in test but not when turned on

  • 6 December 2019
  • 3 replies
  • 1835 views

Userlevel 2

I am trying to create a completed task in Salesforce when I send an email.

I send the email from our on premise exchange server and use Saleshandy to track them.

I set up the Zap to catch a webhook when Saleshandy logs a sent email and check it against a list of my accounts in Google Sheets (to make sure that only my accounts are being updated) and then log a completed email task in Salesforce.

When I run the test, I get the completed task in Salesforce. When I have the Zap turned on and I send an email, nothing happens.

Any help would be greatly appreciated.

Thanks!

Jenn


icon

Best answer by AndrewJDavison_Luhhu 6 December 2019, 18:44

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10

Hi @gwen1299

That's definitely odd!

My first thing to check would be if Saleshandy is definitely firing the webhook, and that there isn't any sort of delay on that?

If that side of things is looking good, the best thing to do is contact Zapier support at contact@zapier.com. They have access to more detailed logs and will be able to see confirm whether or not the zap is receiving any webhooks and see if anything else might be going wrong under the hood.


Userlevel 2

Hi @AndrewJDavison_Luhh

Thanks for the reply. It looks as though not much is happening on Saleshandy's end. Is that likely an issue with them or the webhook created by Zapier?


Userlevel 7
Badge +10

Hi @gwen1299

In this sense, you can imagine Zapier as a passive receiver of data that Saleshandy sends to Zapier.

If it seems like nothing is being sent by Saleshandy then I'd put my money on that being the problem and would contact them to ask. However, it's also worth contacting Zapier as well so they can rule out any issues with the trigger. Zapier support runs 24/7 so you may well hear back from them before Saleshandy.