Best answer

Zap with Gravity Forms trigger wont stay on - keeps turning off

  • 4 August 2021
  • 2 replies
  • 209 views

Userlevel 1

Just FYI, I’ve been fighting with the same problem - if I include a Gravity Form submission trigger, the Zap won’t stay on.

 

I have Zaps running just fine with basic auth - but that is no longer an option. 

 

Every step works in testing BTW.

 

I have sent a message to GetHelp but nothing back yet. 

icon

Best answer by Danvers 5 August 2021, 12:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +12

Hi @philw!

In this case, it sounds likely that the issue is with the connection between Zapier and Gravity Forms. If there’s an error there, then the Zap will turn itself off before it can trigger. 

 

We were able to get some tips from the Gravity Forms team about how to troubleshoot connectivity.

 

The biggest issue we've seen comes when the REST API isn't set up correctly. This is usually caused by the following issues:

  • Basic Authentication is not set up properly on the website. These are at the website WordPress level and they will need to correct this in order to get REST API working. There's a great article for it here: https://help.zaperp.com/article/show/91913-how-to-fix-common-woo-commerce-rest-api-issues
  • Bad redirection rules or a plugin performing redirection that is routing the REST API requests and stripping the POST or DELETE verb from the request. That makes it default to a GET request. This can happen if they have the "www" is left in the "Site URL" or added it if that's not how the site is actually registered. Some redirection plugins may also be causing this issue.
  • Plugins or security settings at the website that are blocking REST API. These are a lot harder to troubleshoot, but we've seen WordFence doing this and there are other plugins or site security settings that they will need to have https://hooks.zapier.com/* whitelisted in order to correct.

Additionally, here are some tips for you while you're attempting to troubleshoot:

  • The Gravity Forms API logging will show the REST API basic authentication and OAuth tests.
  • It also validates that you're connecting the right account.
  • There will be a GET request for every connection attempt, and every time the Zapier setup reads the forms.
  • There will be a post request when the feed is created and at present a delete request when the zap is disabled and a post request when it's enabled.
  • In the Zapier Add-On log, the /standard/ hooks are the new API requests and the /catch/ are the Legacy API requests. Other than that, they look identical.

 

I hope that helps!

Userlevel 1

Thanks so much for all of that information. I took a closer look at the REST API setup in my Gravity Forms and the problem was not allowing Read/Write access. I assumed it only needed read as the form is not being updated.

So, all working now! Phew!

 

Thanks again!