Question

Zap app works in test mode but does not generate a task

  • 10 October 2020
  • 8 replies
  • 532 views

Userlevel 1

Hi,

 

I’ve setup a Facebook Lead Trigger that connects to Mail Chimp. When setting up the app, I’ve successfully aggregated lead data from Facebook and sent that data to the correct Mail Chimp audience...in test mode only.

 

The app has been live for over a week and isn’t piping any data to Mail Chimp automatically. I checked my Facebook campaign and the account has garnered over 125 leads since the launch of the Zap App. Please Advice.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Check...https://zapier.com/apps/facebook-lead-ads/help

  1. Is the Zap ON?
  2. Is the Zap triggering but resulting in an error? Check here: https://zapier.com/app/history/
  3. Is the FB Lead Ads app still properly authenticated? Check here: https://zapier.com/app/connections
Userlevel 1

Thanks for the reply @Troy Tessalone 

 

Just went through your checklist. Thoughts?

  1. Is the Zap ON?
    1. Yes
  2. Is the Zap triggering but resulting in an error? Check here: https://zapier.com/app/history/
    1. For this specific Zap, there aren’t any results in the task log
  3. Is the FB Lead Ads app still properly authenticated? Check here: https://zapier.com/app/connections
    1. Just tested the connection on both the Facebook Lead Ads & Mailchimp. Results = Success
Userlevel 7
Badge +14

No triggered Zaps means the issue is with the trigger step and thus FB Lead Ads app.

Are the settings on the Trigger step configured correctly?

Check these articles: https://zapier.com/apps/facebook-lead-ads/help

Userlevel 1

@Troy Tessalone 

 

Thanks again for your feedback. And to confirm, this issue still hasn’t been resolved. When I go to edit the zap trigger, and test it, it successfully pulls in updated lead data from the correct campaign ( see screenshot). But nothing is initiating a task log NOR does it automatically push any new subscribers to my Mail Chimp account. 

 

Any other troubleshooting recommendations?

 

 

Userlevel 7
Badge +14

Try testing the FB Lead Ad form form FB with the Zap ON.

Userlevel 1

@Troy Tessalone 

 

Just tested it and it’s pulling in updated leads from today once I refresh the data pull within the Facebook Leads trigger. But still no task is initiated or data is pushed to MailChimp. And confirming the zap is on.

 

 

I have the same problem @Number38 did you fix it?

Userlevel 7
Badge +8

@Number38 - Did you happen to discover the answer by chance? If you did, let us know on here so other users may learn from it too!