Question

Wordpress zap can't find posts

  • 22 August 2020
  • 5 replies
  • 265 views

Userlevel 1
Badge

HI,

I need to find a post with a dynamic tag extracted from a google sheet. 

Choosing the “Find Post” zap it returns one required filed “customize post” field (odd ...). 

  • When I enter the post ID it returns a “couldn’t find search terms”
  • If I enter the post name it returns an error : “WordPress ran into an issue. Error code 404: Invalid post ID.“

Is it a bug or am I missing something?

Thanks,

Alex


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +7

Hi @Alex834 ,

Can you give some more details? Please be more specific of your questions. 

  • What do you have in triggers/actions? What kind of systems & fields do you use?
  • What is the expected result you have?
  • Some screenshots of your workflow would help

Let us know!
~Bjorn

Userlevel 1
Badge

 

I want to use “Find Post” in various zaps and so far it has not been working anywhere for me.

One of the zap, the trigger is a webhook submission from WPForms which contains the post ID and the post title.  I expect to get back the entire post so I can extract some fields (which I do successfully on a “New Post” trigger).

 

 

 

Thanks for the help,

Alex

Userlevel 1
Badge

Bump

Userlevel 7
Badge +11

Hi @Alex834!

It’s hard to say what might be causing that problem, but as a test would you be able to try searching for a different WordPress post using that step in the Zap editor? Ideally, something without any special characters at all. I know we have an issue with the & symbol preventing searches from working. I’m wondering if the - in your title may be the culprit.

Userlevel 7
Badge +8

@Alex834 ,

Checking in to see if you were able to get this Zap up  and running! If so, would love to know how!