Question

Webhook returns internal server error connecting Paypal to WooCommerce

  • 5 March 2020
  • 6 replies
  • 349 views

Userlevel 3

I need to use the Paypal IPN for two services. So, following the Zapier guide, I created a Webhook that sends a POST request to this URL https://italianindie.com/?wc-api=WC_Gateway_Paypal. It's the WooCommerce IPN URL for Paypal.

I've been using the same URL for months and it works. Orders and refunds are correctly processed.

But when I test the Zap, it gets an internal server error. How can I fix this?



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +12

Sorry that you're having some trouble with your Zap! When you say that you've been using the URL for months and it worked, do you mean that you've been using the URL in the Zap and the whole thing has been working, or have you been using the URL for something else?

Could I also ask how you've set up your Zap? You said that you followed the instructions here, is that right?

PayPal - Integration Help & Support | Zapier So you've go the new Zapier url in your IPN field in PayPal and are using Zapier to send information to your old paypal IPN, is that right?


Userlevel 3

Hello,

I've been using the IPN URL in WooCommerce for months.

I used exactly the procedure you linked.


Userlevel 7
Badge +12

Thanks for confirming that, @albertocv 😊

So is the issue that you're getting an error when you test the Zap specifically? Or has it started to run into errors when it's turned on?

If it's just when you test the Zap, it may be that there's something in the sample data that's causing the issue.

If the Zap is continually running into errors when it's turned on, are they all they same ('Internal Server error') and is there anything else on the error message? If there is, could you please share a screenshot of it?



Userlevel 3

Thank you. It's an error while testing. Support didn't suggest that it could work with real data.

I didn't turn it on because it involves a critical part of the purchase process.

So, to have a definitive answer should I try a real transaction?


Userlevel 7
Badge +12

Hi there, I’m sorry for the delay in replying here! Are you still seeing this error? You mentioned that Support didn’t suggest that it would work with real data - do you mean that you got in touch with PayPal’s support team? It doesn’t look like you’ve reached out to the Zapier support team (unless you did so from a different account). If you haven’t contacted our Support team and you’re still having an issue with this Zap, then that would be the best next step here. 

 

I’m sorry that I don’t have a better answer for you right now!

Userlevel 7
Badge +11

Hi @albertocv!

Since this was a little while ago, I wanted to check in to see if you’d managed to solve this or whether you still needed help here. Please let us know!