Best answer

Unable to connect to Neto

  • 16 April 2020
  • 1 reply

Hi There,


I’ve had several Zaps connecting to Neto where is my online store built from. I’ve had them for a while and they were working fine until today I was told to reconnect to my Neto account. I wasn’t able to as when I filled in the API details, I got error message like this “authentication failed: It seems like you haven't added a New Customer in the last hour! Make sure you create a New Customer and try again!”


I don’t know what it really means. But I deleted my current Neto connection and tried to add a new one. Then I saw there’re two Neto apps. The one I used before “Neto 1.30.0” was maked “Deprecated”, and there’s another one just called “Neto”. So I tried them both, but with the old one I still got the same error message and with the new one, the pop up window will just go on for a while tring to load and then shows “Oh, man! Something went wrong on our end. Please close this window and try again.” And no matter how many times I tried, it was still the same.


So does anyone know how to solve my Neto connection problem? Btw I haven’t touched anything settings both on Zapier and Neto sides, so I don’t know why it went wrong at the first place.


Many thanks in advance!


Kind Regards,



Best answer by nicksimard 17 April 2020, 19:19

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +11

Hi Noah,

Based on the error message that you provided, it seems like Neto needs you to create a new customer within the 60 minutes prior to trying to connect to Zapier. I’ve never seen that type of error during the authentication stage but that message comes directly from Neto so I’d say that’s your best bet as a first step.

Have you tried creating a new customer (this can be using dummy data) and after that, try connecting Neto inside of Zapier?