Question

Tagging Users on Teams Chats Using Zapier


Userlevel 1

Hi all,

Does anyone know if there’s a way to tag Microsoft Teams users directly in chats (not channels) using Zapier? I’ve tried the code below with no luck - it posts with the <at>example</at> as is without tagging the user.

Not working in Teams chats: To mention team members, put their display name, email, or userID between “at” tags. For example, you could use <at>Jane Doe</at>, <at>jane.doe@example.com</at>, or <at>jane-doe-user-id</at> to mention a team member "Jane Doe".

Any help would be greatly appreciated!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +6

Hi there @Falyn,

Welcome to the Community! 🎉

Before we dig deeper into this, could you please share a detailed screenshot of how your Zap is configured? Also, a complete screenshot of the "Action" section in Microsoft Teams, including all the fields of the action step Here’s an example screenshot:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

I’m having the same problem. I’ve tried every singleformat but it never mentions the person I want to tag on the teams chat

Userlevel 7
Badge +6

Hi @gheanger,

I’m so sorry if you’re experiencing the same issue with tagging users on teams chat.

Before we dig deeper into this, I'd like to see the entire “Action” section of the Microsoft Teams action step so I can review all the selected settings and fields in case there's something on the set up that's preventing it from working as expected. Here’s an example screenshot:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

Userlevel 1

Hi @ken.a ,

Apologies for the delayed response. Here’s a screenshot of action step, though I’m fairly positive this feature doesn’t work in chats - only in channels. Let me know if there’s something I’m missing here, but I ended up using Power Automate for this functionality instead.

Userlevel 7
Badge +6

Hi @Falyn,

Thanks for the screenshot!

Thanks for letting us know that you found a different solution about this one. However, could you please try this code instead: <at id=\"0\">Jane Smith</at>

Please give that a try, and let me know how it goes.