Best answer

Salesforce/Slack: Include link to Salesforce record in Slack alert

  • 21 January 2021
  • 3 replies

Userlevel 1

How can I include a link to a Salesforce opportunity record in a Slack alert? 

I found this article with a picture (see attached) showing how to build a link but it doesn’t work when I follow the format using my company’s details. I receive the error:

Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.


Someone who was previously with the company had the link working on the same object and no sharing permissions have changed since then. I’ve searched everywhere and can’t find any documentation on this. Everything else in the Slack alert is working.





Best answer by Gillian 21 January 2021, 10:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +14

Hi @Gillian 

Try deconstructing a link of a Salesforce Object that you know clicks thru.

Then find the corresponding Salesforce Object ID from the trigger step.

Userlevel 1

Thank you Troy, but still no luck.


Here is a link that worked through an old Slack alert:

When I replace the existing ID (0063k00000zmFu8AAE) with the Opportunity Record ID found in SFDC (01261000000XzxEAAS), I get this error message:

Looks like there's a problem.

INVALID_TYPE: sObject type 'RecordType' is not supported in describeCompactLayouts.


Thinking maybe it’s not letting me switch out the IDs since the ID from the link is the unique Opportunity ID rather than the Opportunity Record Type ID that I pasted in. Any other ideas?


This is the link I tried originally, which has a different domain (found from My Domain in SFDC) and returned the insufficient privileges error message:



Userlevel 1

I figured it out - I was pasting the object ID as text instead of inserting it as a field from the dropdown list. 


Thanks for your help