Question

Required field "Relator" (user::reporter) is missing (JIRA CLOUD)

  • 30 August 2021
  • 6 replies
  • 495 views

Hi,

I'm having an issue when I try to update the status of a task inside a board using Zapier (Jira Cloud Software).

I've created the zap initializing with the trigger, New Response in Spreadsheet in Google Forms, which creates a new task into a jira's board and then create the a new task into a new board referencing the previous created task.

And this last task that i ask Zapier to create I wanted it to have the status updated to a new column, so I created 2 new steps, 1 to search the task by the issue key, and other to update the status, and when I tried to test, I get this following error:

 

there's no field where I can inform the relator, it's already informed at the step where I've created the task as you can see in the image below:

 

Please, can you help me?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @Mirella 

The error indicates that Jira is expecting a required field to have a value (Relator), but it is missing.

Perhaps you can post screenshots of how your Zap steps are configured.

Hi @Troy Tessalone, thanks for your reply, as I said I send this informations only when I create the task, and there's no fields where I can informe the relator again.

  • This is the entire automation, the step 2 and 3 are just the same, the only thing that changes is the name of the board.

 

  • How I create the step 3

 

  • The step to find the issue

 

  • The step where I'm having the problem, after this it can't turn the zap on because it send me the error where the field relator is missing

 

 

Userlevel 7
Badge +14

@Mirella 

Fields not showing up in Create Issue action

Check your Project to make sure the field you want to use is available.
Check that your user role has permission to update this field.

Hi @Troy Tessalone,
This field exists and is showing when I create the task, according to the screenshots I sent you in the previous answer, what is happening is that, when I update the task status, it asks me for this field and there is no such field to inform , my user is board administrator.

Userlevel 7
Badge +14

@Mirella 

Probably best to open a ticket with Zapier Support for further assistance on this issue: https://zapier.com/app/get-help

Userlevel 1

@Mirella have you opened a support ticket? Did you get any answer? I am asking as I have a very similar issue and so far did not manage to find any workaround.