Best answer

Not all my Zaps are all triggering instantly

  • 16 May 2021
  • 2 replies
  • 170 views

Hey everyone,

 

I’ve been using Zapier integrations for a while now and i’ve been really happy with some zaps, while others don’t seem to work like they should be. 

 

The biggest problem i’ve been having is some of the zaps don’t trigger like they should. I have everything set up, run a test and the system works perfectly. Although when i turn on this specific zap and allow it to work like it should it doesn’t fire or send any of the information. When i go back in a check on the zap, everything looks ok. If i refresh the customer field to the new customer who should have triggered the zap and git test, all the info gets sent on the spot. 

 

Is there a reason why some of my zaps aren’t working automatically but when i go in and test the zap with the new triggered information it works fine. 

 

Any help would be appreciated. 

 

Thanks 

icon

Best answer by Paolo 8 July 2021, 06:15

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @DevinT 

FYI: Some Zaps have INSTANT triggers, otherwise the Zap trigger time depend on your Zapier plain, which can be from 1-15 minutes.

I suggest looking at your Zap Runs here to see if the Zap actually did trigger in due time: https://zapier.com/app/history/

Example:

 

Userlevel 3
Badge +5

Hi @DevinT, just checking in to see if you still need help with this?

To add a bit more context, here’s a help doc that explains the difference between Polling and Instant Zaps which determines how fast data is processed: https://zapier.com/help/create/basics/set-up-your-zap-trigger#trigger-types

I hope that helps!