Question

Integrating a Google Forms into my Systeme.io account?

  • 13 February 2024
  • 6 replies
  • 36 views

Badge

I’ve been trying to get this zap to work for 2 days and have given up on typeform so am now trying to use google forms to collect and tag leads and put them into a campaign. I am able to select the email field (pic 1)  and then when I test it I get the email error (second pic)

I’m starting to think systemeio isn’t compatible with zapier. Has anyone experienced this issue?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @tiana 

The error indicates the mapped variable had no data (missing/empty/blank) when the Zap ran.

Check your Zap Runs history details to see the DATA IN/OUT for each step: https://zapier.com/app/history/

Make sure the email field is required on your form app.

If you rename the email field on the form app, then you may need to remap your Zap steps.

Help article about how to change your Zap trigger data: https://help.zapier.com/hc/en-us/articles/8496310366093

Badge

Thanks Tony - the links you sent aren’t really helping me fix this issue.

 

The google form has a field title ‘email’ but this option isn’t available in the dropdown on Zapier. The only field that it accepts is respondent email which is simply a test email. So the zap ends up failing.

 

I’m also a bit lost with the records issue. I assumed that when I was mapping the zap that the fields would be identical so I could easily select ‘email’ from the list and add it in.

 

Is there a video demonstration of this being done? I also tried this with a different CRM and it still didn’t work.

Badge

It makes me add in an actual email address which doesn’t make sense since I am asking it to collect email addresses. This test was a blank email and i got the same message.

Userlevel 7
Badge +14

@tiana 

This looks like dummy data.

Have you tried testing the GForm, then refresh the Zap trigger step for new data using the [Find New Records] button?

Help article about testing your Zap: https://help.zapier.com/hc/en-us/articles/8496310366093

Try turning the Zap ON and testing live.

Then check the Zap Runs history to see the DATA IN/OUT for each step: https://zapier.com/app/history/

 

 

You would likely map the field with an email value to the Email field in Step 2.

Help article about configuring Zap actions: https://zapier.com/help/create/basics/set-up-your-zap-action

 

Badge

I’ve done all of what you’ve suggested, I just don’t think Zapier works or it’s not as straight forward as it appears to be. It is not linking with anything I try. I’ve tried 2 different forms platforms (google forms and typeform) and I’ve tried 2 different CRMs (systeme and flodesk). The form fields don’t sync correctly in Zapier to make it work. I will keep trying but I don’t think it will work.

Userlevel 7
Badge +14

@tiana 

If you need help, consider hiring a Certified Zapier Expert: https://zapier.com/experts