Best answer

I continually get error warning emails about my Xero zaps and when I check in they are fine, there are no errors in the log

  • 17 November 2020
  • 5 replies
  • 248 views

Userlevel 1

I get errors like this regularly on various Xero zaps.

Xero: ExternalHTTPSConnectionPool(host='api.xero.com', port=443): Max retries exceeded with url: /api.xro/2.0/Payments?order=Date+DESC&where=Status%3D%3D%22AUTHORISED%22+AND+Date+%3E+DateTime%282020%2C11%2C09%29+AND+PaymentType%3D%3D%22ACCRECPAYMENT%22 (Caused by ConnectTimeoutError(<useful.request_extras.ExternalHTTPSConnection object at 0x7f1ce24e6f40>, 'Connection to api.xero.com timed out. (connect timeout=30)'))

When I check the task log all ran okay and there are no errors.

This only happens with Xero.

Its a huge time waster, does anybody else have similar issues?

icon

Best answer by steph.n 19 November 2020, 02:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Yes, I have the same issue also. Only started this ZAP today from a google sheet to Xero. Hopefully it is only a temporary issue with XERO. 

I’m getting this too - any way of getting around it? Do I have to reconnect / reauthorise anything? 

Userlevel 1

Its not a temporary thing unfortunately, it has been going on for a while with me.

 

Userlevel 7
Badge +8

Hello everyone, popping in here to let everyone know that a bug report has been filed for this issue and will have an ongoing investigation. Each of you in this topic has been added as an impacted user. We will reach out to you directly once this issue has an update.

Thank you!

Userlevel 1

Thanks, look forward to the update