Best answer

How do I handle a null value for time from Monday on Google Calendar entry

  • 27 May 2022
  • 8 replies
  • 92 views

I am creating a google calendar entry for a delivery date/time column in Monday.  Once the delivery is scheduled, I only know the day.  The zap errors out because no time was entered.  I would like to set a default time in my Zap to midnight or 1am since I don’t know the timeframe until the day before the delivery.

icon

Best answer by Troy Tessalone 27 May 2022, 20:42

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @YHowe 

Good question.

You can set a static time value as part of the GCal field.

OR

You can use Formatter > Text > Default Value.

My apologies, Troy - I’m very new.  Is this set in Zapier or Monday.  FYI - I’m currently using the free plan version of zapier.

Userlevel 7
Badge +14

@YHowe 

Please post screenshots with how your Zap steps are configured in order for us to have more context, thanks.

 

Thanks, Troy - per my email above, we get a delivery date a few days after a record is created for the customer.  Then, as the delivery date approaches, we get a time.  Since I don’t have the time when the zap runs to create/update the entry in Google Calendar, the Zap errors out with a Status Code 400 Bad Request - it’d be ideal if we could get a default time set for when the value is null. 

 

Monday

 

 

 

Zapier

Userlevel 7
Badge +14

@YHowe

You can set a static time value after the date for these fields.

e.g. [Cab Delivery] 12am

 

Setting the time to 12:00a does not allow the time to update when I set it to the actual delivery time in Monday - the time remains set to 12:00a.

Userlevel 7
Badge +14

@YHowe 

Please clarify what Monday Zap trigger event you are using.

This help article provide info about how to use the Formatter > Text > Default Value step that can be used to check if a value exists and if so use that value, else use a default value: https://zapier.com/help/create/format/set-default-values-for-blank-fields-in-zaps

NOTE: Zaps with 3+ steps require a Zapier paid plan.

Thanks, Troy - I assumed it was a limitation of the plan I am using.  Thanks for the additional info.