Best answer

HELP Resource Guru - Error Message: Cannot convert undefined or null to object

  • 24 March 2021
  • 4 replies

Trigger: Resource Guru - New Project
Action: Google Sheets - Create New Row

I tried test pushing data to only 1 column in google sheets, comes out error message: “Cannot convert undefined or null to object”

Please help, I think there might be a bug from the Resource Guru’s data inputs.



Best answer by SamB 18 June 2021, 09:57

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @jemhangrid 

Might be best to open a ticket with Zapier Support here for them to troubleshoot:


I am also seeing this same error when trying to activate a Zap for Resource Guru. My RG test trigger was successful and I’ve verified all required fields in the trigger are populated. Has anyone found a resolution to this? If not, I’ll reach out to Zapier Support.


Userlevel 7
Badge +11

Hi @justtryingtomakeazap!

I see that you’ve written to our Support team and they have responded with some directions and also some questions. Please continue the conversation there, since they’re able to dig into your Zaps :)

@jemhangrid I see that you also reached out to our Support team and we didn’t hear back after we responded to your message. You can continue that thread so they can look into your issue.


Userlevel 7
Badge +11

Hey @jemhangrid!

I just wanted to check whether you were still running into that error here?  If so, it seems that the connected Resource Guru account will error if it doesn’t have full Admin permissions. Hope that helps!

@justtryingtomakeazap, it looks like our Support team were able to help you get rid of that error already. :)