Best answer

Function IF(result=name), doesn't work

  • 2 February 2021
  • 11 replies
  • 178 views

Hello, 

I’m trying to use formatters numbers through a Spreadsheet-Style Formula connected to a typeform 

It’s mainly numbers except for that step where I have to put some conditions regarding the result of the first result and apply a different formula.   

 

I’ve put 

IF(en périphérie de ville ( zone commerciale )=périphérie, 400,[400/100*65])

 

I’ve got the error : 

Error parsing response. We got: "<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN"

<title>500 Internal Server Error</title> <h1"

 

icon

Best answer by Troy Tessalone 2 February 2021, 18:20

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

11 replies

Userlevel 7
Badge +14

Hi @CatapulZ 

Can you provide screenshots of how your Formatter step is configured in the Zap?

 

 

 

 

Userlevel 7
Badge +14

Hi @CatapulZ 

Try putting double quotes around the first dynamic data point so the formula evaluates properly.

 

Otherwise, it appears the resulting formula has extra parenthesis which impacts the way the formula is evaluated.

 

Thank you  ! it works ! 

 

Unfortunatly the next one doesn’t work tooo…   How can we make understand to Zapier we just want the value from the formula not the formula in it-self ? 

Calculation is weird 

Userlevel 7
Badge +14

@CatapulZ 

Would have to see screenshots of the new use case in order to evaluate and advise.

I dont’ get why this formula doesn’t work 

Userlevel 7
Badge +14

@CatapulZ

Remove the enclosed square brackets [ ] or try replacing with parenthesis ( ).

Also looks like there may be an extra line break.

 

Userlevel 1
Badge

@CatapulZ Hey there! I know it’s been a while but I wanted to check in and see if this suggestion helped with your second Zap?