Question

Excluding all replies from Zap's post to discord

  • 11 April 2023
  • 9 replies
  • 38 views

I’ve been trying for the last week to set up a filter that excludes all replies from the user being reposted in my discord. The options available seem to only be available to users that have previously replied. 

 

I’ve set the filter up to “continue only if” and tried several of the reply and retweet options set to does not exist yet the replies keep posting. The option that seems to make the most sense is “In Reply to Screen Name” but the drop down menu only has specific user names already filled out in a field that I cannot edit. Is there a way to blanket exclude ALL replies from the user?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +6

Hey there @pendulum,

Welcome to the Community! 🎉

Before we dig deeper into this, could you please share a detailed screenshot with how your Zap is configured? Please don’t include any personal information in the screenshot.

Thanks! 😊

Hi @ken.a and thank you for you help. This is the most recent version (which won’t publish at the moment either and not sure why). I’m not using search terms in my trigger. From what I’ve read in previous questions that would lead to the need for a filter. But whatever I seem to set the filter to exclude either has user/status specific elements in it that I cannot change or doesn’t prevent the tweet from passing on to the action step. 

Userlevel 7
Badge +6

Hi @pendulum,

Thank you for the screenshots!

I did some digging into this, and it seems like for the Zap to exclude replies from tweets you may need to add a filter step that looks like this:

  • User Screen Name - Exactly Matches - Type the twitter username you inputted in the trigger step
    + AND
  • In Reply To Screen Name - Exactly Matches - Type the twitter username you inputted in the trigger step

Please give that a try, and let us know how it goes! 

@ken.a thanks for that. It helps some and I see how that is set up but, I’d also like to not have replies to their own tweets. Just the initial one by the OP

Userlevel 7
Badge +6

Hi @pendulum,

We can try this another setup for the Filter step:

  • User Screen Name - Exactly Matches - Type the twitter username you inputted in the trigger step
    + AND
  • In Reply To Screen Name - Does not exist

Please give that a try, and keep us posted.

Thanks! 😊

Hi @ken.a My original filter had something similar to this. The problem I’m running into is the drop down options for “In Reply To Screen Name” only come with preset fields that I cannot edit. Example in the screenshot below. If there were a blanket “In Reply To” option, that would be exactly what I’m looking for but that doesn’t seem to be the case when I try to set it up. 

 

 

Userlevel 3
Badge +4

Hi @pendulum 

Could you also send a screenshot of what you see when you try to set it up? (If there’s any personal information, kindly blur them.)

Looking forward to your response! 😊

Hi @Charie. Are the first screenshots not what you’re asking for? Excuse my ignorance, I’m rather new to all of this. 

Userlevel 3
Badge +4

Hi @pendulum 

Not a problem. My apologies for not clarifying.

So what I’m looking for is how you’ve set up the Zap so far. The steps of the Zap, like so:

(If there’s any personal information, kindly blur them.)

Hopefully this helps.