Question

Publishing Tasks Not Updating

  • 20 June 2023
  • 4 replies
  • 35 views

Userlevel 1

I’m trying to work through publishing tasks to validate an integration for publishing. Publishing tasks don’t update as I resolve issues. 

 

Example: I get a publishing task stating

    • Description should be 1-3 sentences, at least 40 characters, and no more than 275 characters. found 569 characters and 4 sentence(s)

 

I reduced the number of sentences and characters in my Zapier code, ran zapier build, and ran zapier upload. My new version showed up in the UI and I clicked on it. I’m still getting the same warning with an identical character and sentence count. I’m also having this happen with all other error types, such as missing id field. That’s just an example. I tried clearing my cookies and browsing data. That didn’t help. Any suggestions?

 

Thanks


4 replies

Userlevel 7
Badge +14

Hi @charlotte_anne 

Good question.

To help give us more context, please post detailed screenshots with how your Zap steps are configured, thanks.

Userlevel 1

Hi, here is some more info. I should also mention that I have tried deleting build.zip and source.zip and running zapier build to generate them again. 

 

Here’s an example of an error I’m getting:

And here’s what’s in my code:

 

Here’s the code for get_events:

 

Here’s another publishing task I can’t get to go away:

And here’s the sample data for that one:

 

I’m also getting this:

But this is my character count with spaces when I double check in a word processor:

 

I’m getting this warning when I run zapier build:

 

If I run zapier validate I get an identical response to what I’m getting in the user interface under publishing tasks.

 

Thanks!

Userlevel 1

Update: I have also tried clicking the Re-Run Validation button and that has not changed it either. It seems like old outdated information is being stored somewhere.

Userlevel 1

Solved. Here’s what’s going on.

 

  1. If you start the integration in the UI, but then move to cli later like I did it automatically puts the description under integration settings in the UI into the description in package.json. It does not work the other way around though. If you update the cli version and then upload back to Zapier it updates the triggers and actions, but not the description. You still need to go into the UI to change that manually.
  2. Sample needs to be one individual entry, not a list of entries, even if the zap returns multiple entries at once. If you look at the samples I posted in the code above it’s ok to return data like that, but the sample must look like this:

 

and not like example above that contains multiple of these. In other words, you’ll get an error if what’s returned by the actual zap trigger is not in an array, but you’ll also get an error if what’s in the sample is in an array because it only wants an example of one item in the array.

Reply