Best answer

Download existing CLI converted project AFTER push

  • 11 August 2021
  • 2 replies
  • 259 views

There is an existing CLI app (that has been converted) running live.

I would like to download the app on the local machine to be able to make updates and push it again.

I do not have a local copy of the app at the moment.

I tried running the command:

zapier convert XXX . --version=1.0.X

and it gives me the following error:
 

 Downloading integration from Zapier
» Error: Integration XXXX @ 1.0.X is already a CLI integration and can't be converted. Instead, pick a version that was created using the Visual Builder.
»
» re-run this command with `--debug` for more info

Is there any other way to pull the app source code from zapier?

I also tried multiple versions: 1.0.0, 1.0.1 etc.
 

 Downloading integration from Zapier
» Error: Visual Builder integration XXXX @ 1.0.Y not found. If you want to convert a Legacy Web Builder app, don't pass
» a `--version` option. Otherwise, double check the integration id and version.
»
» re-run this command with `--debug` for more info



I understand the app is deployed and run from an AWS lambda function.
I went through the docs twice now and could only find info about how to build and push, but pretty much nothing about pull.

icon

Best answer by Zane 12 August 2021, 17:53

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +9

Email partners@zapier.com from the email address associated with the Zapier account of an admin on your Zapier integration. Ask them to email you a zip file of that app version.

After you upzip it, use zapier link to associate it with the deployed instance on the Zapier platform. 

Then, be sure to push the project to your team’s git repo! :relaxed:

Thank you, already sent an email, waiting for response. 
Of course we will push it to the repo :) 

Good advice about using zapier link