Best answer

Unsubscribe hook doesn't work

  • 9 July 2021
  • 9 replies
  • 72 views

HI,
API endpoint of unsubscribed zap is not getting called when we turned off the zap.
I have attached the remote debugging and put a debugger point in endpoint and tried to turn off the zap but the debugger point never hit in my service.

Thanks

 

icon

Best answer by CBFS 16 July 2021, 14:25

I’ll chip in as this is an issue that I’ve discovered on Monday (2021-07-12).  So the issue here is that there was a big release on monday that changed quite a few things, one of which is that `performUnsubscribe` is called with a 20-30min delay.

 

Other notable changes:

  • if there is an error during `performSubscribe` call, the zap frontend will not show your error, nor it wont block the “ON” option, so after you refresh te zap editor, your zap will be “OFF”
  • the `bundle.meta.zap.id` is useless now, as it refers to “subscription ID” rather than “zap ID”

Hi @CBFS , thanks for the response
Is there any way we can fixed that delay or I need to wait for developer to fixed the delay issue performUnsubscribe

 

There was no way to fix that, but there is no need, as I’ve got confirmation form the support that this change was reverted; tested it myself and it works like previously.

View original

9 replies

Userlevel 7
Badge +10

Hi @shweta 

Can you post screenshots of how you have this unsubscribe feature configured?

HI @Troy Tessalone 
in trigger I have setup unsubscribed like the below screen shot

 

I’m noticing this change too today. Earlier when you turn off a Zap, unsubscribeHook request was triggered. But no such request is made now. However, every time you unpause the Zap, a fresh subscribe request is being sent.

Userlevel 7
Badge +11

Hi @shweta!

 

It looks like you’re working on a Zapier integration using the Zapier Platform for developers, is that right? If so, you could take a look at this post to see if it helps as this member was having a similar issue: 

 

I hope that helps!

I’m noticing this change too today. Earlier when you turn off a Zap, unsubscribeHook request was triggered. But no such request is made now. However, every time you unpause the Zap, a fresh subscribe request is being sent.

yes , subscribe hook called every time when ever I am turning on the zap but when I tried to turned off the zap unsubscribed hook does not trigger

Hi @shweta!

 

It looks like you’re working on a Zapier integration using the Zapier Platform for developers, is that right? If so, you could take a look at this post to see if it helps as this member was having a similar issue: 

 

I hope that helps!, 

HI @Danvers , i am not using the Zapier Platform for developers, the screen shot which I have shared is the code mode of the unsubscribed section.

I’ll chip in as this is an issue that I’ve discovered on Monday (2021-07-12).  So the issue here is that there was a big release on monday that changed quite a few things, one of which is that `performUnsubscribe` is called with a 20-30min delay.

 

Other notable changes:

  • if there is an error during `performSubscribe` call, the zap frontend will not show your error, nor it wont block the “ON” option, so after you refresh te zap editor, your zap will be “OFF”
  • the `bundle.meta.zap.id` is useless now, as it refers to “subscription ID” rather than “zap ID”

I’ll chip in as this is an issue that I’ve discovered on Monday (2021-07-12).  So the issue here is that there was a big release on monday that changed quite a few things, one of which is that `performUnsubscribe` is called with a 20-30min delay.

 

Other notable changes:

  • if there is an error during `performSubscribe` call, the zap frontend will not show your error, nor it wont block the “ON” option, so after you refresh te zap editor, your zap will be “OFF”
  • the `bundle.meta.zap.id` is useless now, as it refers to “subscription ID” rather than “zap ID”

Hi @CBFS , thanks for the response
Is there any way we can fixed that delay or I need to wait for developer to fixed the delay issue performUnsubscribe

I’ll chip in as this is an issue that I’ve discovered on Monday (2021-07-12).  So the issue here is that there was a big release on monday that changed quite a few things, one of which is that `performUnsubscribe` is called with a 20-30min delay.

 

Other notable changes:

  • if there is an error during `performSubscribe` call, the zap frontend will not show your error, nor it wont block the “ON” option, so after you refresh te zap editor, your zap will be “OFF”
  • the `bundle.meta.zap.id` is useless now, as it refers to “subscription ID” rather than “zap ID”

Hi @CBFS , thanks for the response
Is there any way we can fixed that delay or I need to wait for developer to fixed the delay issue performUnsubscribe

 

There was no way to fix that, but there is no need, as I’ve got confirmation form the support that this change was reverted; tested it myself and it works like previously.

Reply