Best answer

Unable to setup Zapier for development

  • 25 May 2022
  • 1 reply
  • 19 views

I am trying to set up a new dev machine. I run the command as specified in the documentation but I get many warnings and when it's done I get the following when I try to run the zapier command to login. Seems like the installation is just not working anymore. Does anyone have any idea how to fix this?

'zapier' is not recognized as an internal or external command,
operable program or batch file.

 

I have Visual Studio 2019,  Visual Studio 2022, and Visual Studio Code installed.

npm install -g zapier-platform-cli

npm WARN ERESOLVE overriding peer dependency
npm WARN While resolving: marked-terminal@4.1.1
npm WARN Found: marked@4.0.10
npm WARN node_modules/zapier-platform-cli/node_modules/marked
npm WARN marked@"4.0.10" from zapier-platform-cli@12.0.3
npm WARN node_modules/zapier-platform-cli
npm WARN zapier-platform-cli@"*" from the root project
npm WARN
npm WARN Could not resolve dependency:
npm WARN peer marked@"^1.0.0 || ^2.0.0" from marked-terminal@4.1.1
npm WARN node_modules/zapier-platform-cli/node_modules/marked-terminal
npm WARN marked-terminal@"4.1.1" from zapier-platform-cli@12.0.3
npm WARN node_modules/zapier-platform-cli
npm WARN
npm WARN Conflicting peer dependency: marked@2.1.3
npm WARN node_modules/marked
npm WARN peer marked@"^1.0.0 || ^2.0.0" from marked-terminal@4.1.1
npm WARN node_modules/zapier-platform-cli/node_modules/marked-terminal
npm WARN marked-terminal@"4.1.1" from zapier-platform-cli@12.0.3
npm WARN node_modules/zapier-platform-cli
npm WARN deprecated source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated cli-ux@4.9.3: Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.
npm WARN deprecated cli-ux@5.6.7: Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.
icon

Best answer by brianj 25 May 2022, 22:21

View original

1 reply

Okay, I figured out my own problem. It's been a while since I worked with Zapier and I didn’t realize that old version v14 must be installed. It was the “current” version the last time I set up a dev environment.

Reply