Question

How to change Zapier Node Version?

  • 17 September 2022
  • 1 reply
  • 10 views

Zapier cli docs state that All Zapier CLI apps are run using Node.js v6.10.2.. Our app is built using the cli.

Elsewhere in Zapier docs it states that The environment is vanilla node.js v4.3.2 which runs JavaScriptcorewalking

We already did z.console.log('node version', process.version); from within the Zapier app so that we can see the node version where it is run. We retrieved this using zapier logs. The version logged is 4.3.2.


1 reply

Userlevel 4
Badge +7

Hey @jordanwilliom 👋

In the docs you’ve linked, one is to Code by Zapier, which allows you to use a Code step in an existing Zap (without building an app).

The most current CLI docs (for developing your own app on zapier.developer.com) can be viewed here: https://github.com/zapier/zapier-platform/blob/master/packages/cli/README.md#requirements and new Zapier CLI apps are run using Node.js v14.

You can develop using any version of Node you'd like, but your eventual code must be compatible with v14.

To manually set the node version, see the faq here: https://github.com/zapier/zapier-platform/blob/master/packages/cli/README.md#how-do-i-manually-set-the-nodejs-version-to-run-my-app-with

Hope that this helps clarify things! If you have further questions, let us know if you are developing your CLI app, or using a Code step in a Zap, as they are two different things 👍

 

 

Reply