Question

Couldn't find a client message while testing the trigger

  • 13 January 2021
  • 2 replies
  • 18 views

I have created a Test Zap Integration using the Zapier Platform UI. I am using API_key as the authentication method. 

I created a Trigger with the Subscription and unbsubscription apis using Resthooks option. When I test my trigger, I am getting the below message. 

 

What does this message indicate?

 

Below is the subscribe and unsubscribe configuration.

 

 

Any help regarding this will be greatly appreciated.

 

Thanks,


2 replies

Userlevel 4
Badge +6

“client” is what you named the “noun”, or object type, that this trigger consumes.  What the message is saying is that you API did not return any objects when your integration queried it.  Without an object to work with the editor here doesn’t have data to use to map into field in subsequent action steps, and so it presents that error message.  So make sure you have some data in your test account, make sure you’ve implemented the “Perform List” polling request (this is used to fetch sample objects rather than waiting for a hook to be sent) and you should get past this message.  

 @Zane - Thank you for the reply. I was able to fix this error. I now have a different issue. 

I have submitted a different ticket for this here:

Can you please take a look and let me know. 

Also as you have mentioned in your reply about “Perform List”, I do not know how to use it. Can you please throw some light?

 

Thanks.

Reply