Best answer

Can't upload my logo

I have my logo in a 1024xX1024 PNG format. However, every time I tried to upload it, I get a message saying it’s in the wrong format or corrupted??

I also tried resizing it to 256x256, still same error


What do I have to do to fix this? I’m using Snagit 13 to create the PNG ..


Best answer by ikbelkirasan 20 May 2022, 17:40

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +13

Hi @ElixirMike 

Good question.

Please clarify where and how you are trying to upload your logo, thanks. (screenshots are best)

From the settings page.  I drag the logo on the “Select image”. It correctly shows the icon.

I click “Update” and then I get the error message. 

I’ve attached the 1024x1024 PNG Transparent icon as well.












Userlevel 7
Badge +11

Hi @ElixirMike - You can create a valid logo in Photopea - Start with a blank transparent 512x512 pixels image then import your logo, resize it to fit inside the image. Once done, export it in PNG format and upload it to your Zapier app.

Well, I believe there was a bug on the Zapier side. I woke up this morning and tried again to upload the exact same logo that failed yesterday, and this time it uploaded without incident.

So either someone fixed something on the Zapier side, or there’s an intermittent bug with uploading logos.

But, it’s finally uploaded, so I’m good there. Now I’m having an issue with my “Test trigger” and it not finding any updates, even though I can see that my API is returning records. Seems like a bug, but don’t know how I get it resolved.

Will probably submit another ticket.