Question

API Key authentication not working - what endpoint response is needed?

  • 7 September 2021
  • 1 reply
  • 25 views

Hello. 

Im trying to build a zap from the CLI. We want to use an API Key as auth. We have generated some api keys to each user and only need to set it up on the zapier half. 

From the documentation i have setup the initial settings for API Key auth, you get prompt for a API key when you try to use this zap. However it doesnt seem to authenticate.. My question, what reponse from the endpoint called when entering the api key is needed for this to work? At the moment im returning the user in json format when you go the my /me endpoint. 

However im pretty sure its my endpoint thats wrong.. What should this /me endpoint look like and what should be returned? Hope someone can help out - thanks.


1 reply

Userlevel 7
Badge +9

With API key auth Zapier is just looking for a HTTP 200 response, along with the payload of whatever request was made. There’s no discrete handshake step.

Remember to include your auth header in every request. If you’re using the UI, we try and set some defaults, but if the header name you need doesn’t match what you used as the key name for the auth input field, the defaults will be wrong and you’ll need to correct those.

Check your logs (in the monitoring section of the UI), as well as on your server and confirm that the request is being formed correctly and watch where/why the server is rejecting the request.

If you have a request that’s working (in postman, etc) compare the working request against the Zapier log and spot the difference.  Armed with that, you can come back here and get help coercing your Zapier integration to make the request get emitted the way you need it to.

Reply