JSON webhook error - “Not all required keywords are provided”

  • 1 September 2021
  • 1 reply

Userlevel 1

This post was split from the topic: Looping by Zapier not iterating through

Well, now I can’t get the API to respond correctly in the next step. The data payload should look like this:


I delivered this exact payload via cURL. The API responds as expected.

However, when I try to duplicate it in Zapier, it fails. Here’s how i set it up:

That didn’t work, so I tried doing raw format. That didn’t work, so I tried JSON again but using double-underscore nested values - but the data sent included the double-underscore instead of the nested values.

Here’s the other attempt:

I tried with array on and off. I also tried with unflatten turned on and off. No change. They both throw the same error. Here’s the results from the second one. You’ll see the un-nested but double-underline being sent as entered instead of parsed to be nested.


This is getting tedious.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 1

I tried the Custom Request method… no dice.


I recreated this request in cURL, which returned exactly what I’m looking for. However, here’s what Zapier returns:

Effectively: a blank response. There has to be a way to perform this API call.