Best answer

Data being passed to bubble with \n is breaking subsequent JSON call

Userlevel 1

I am forwarding emails to my bubble database and then running into issues using that data in subsequent API calls.


It looks like the data from Zapier is passed with a bunch of \n in it. I attached an example of the JSON call being sent from the application.


Is there a way to clean up the text from Zapier prior to sending to bubble? I’ve tried using the “remove html tags” in the formatter, but that doesn’t seem to remove the \n’s.


Any help or ideas would be greatly appreciated.


Best answer by Troy Tessalone 20 July 2023, 13:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @j_makol 

Good question.

Try this Zap action: Formatter > Text > Replace

Userlevel 1

Thanks @Troy Tessalone turns out there were \n and \r messing things up. I ran find and replace on both and everything is working now.