Question

Zoom Meetings are off by 2 hours for some users

  • 10 November 2023
  • 11 replies
  • 77 views

Userlevel 4
Badge +2

We’ve had a Zap workflow working for years without issues. Lately, some users have reported that Zoom meetings that are created via a Zap are off by exactly 2 hours. Eg, the start time of the meeting is 2pm yet the meeting is Zoom starts at 4pm.

We pull the start time from a field in Airtable that is a simple text field with a value like ‘2:00 PM’. Again, this has worked fine for years yet something has changed that is causing this and I’m struggling to figure it out.

Any suggestions for things to try? Thanks if anyone has some ideas for me to explore.


11 replies

Userlevel 7
Badge +14

Hi @donovanwatts 

Good question.

Can you post screenshots with how your Zap steps are configured along with screenshots of a specific example as it’s configured in Airtable along with the DATA IN/OUT as show in the Zap Run steps?

Userlevel 4
Badge +2

Hi Troy, thank you for offering to take a look. One thing I neglected to mention which is making this really challenging to track down is that it is not happening for everyone. Eg, when I create a Zoom meeting for myself, it works fine. However, it’s off by two hours for at least five others that we’ve identified. Those others are in various timezones.

 

We have an Airtable Base whereby we capture the following fields:

- Email - Zoom User

- Topic - Title of Zoom meeting

- Date - Date of Zoom meeting

- Time - Start time to Zoom meeting

- Duration - Length in minutes of Zoom meeting

- Time Zone - Optional

 

Zap Steps for the Zap which creates the Zoom meeting:

Airtable test records showing the fields that Step 3 ‘Create Meeting in Zoom’ pull from:

Data In:

Data Out:

 

Userlevel 7
Badge +14

@donovanwatts 

If you know the timezone, then you may need to adjust using this Zap action: Formatter > Date & Time > Format

There is an option to configure the to/from timezone.

Userlevel 4
Badge +2

Thanks for the suggestion. I’ve added a Formatter > Date & Time > Format step to a test zap i am using but I haven’t figured out what I need to do exactly. There’s so many fields in there for me to tweak that all my experiments have not yet yielded success. I will keep trying tho as I’m sure you are right. If I can figure out what to do with that action step it’ll probably help.

Userlevel 4
Badge +2

After banging my head against the wall, I’m getting closer to a solution now that I’m using a few formatting steps to convert to UTC. However, I’ve discovered a really annoying issue. Overriding the timezone for a Zap does not always stick! This is causing me a lot of grief. I change it. Save the Zap. Next time I return to the Zap, the timezone is set for some other random timezone that I did not select and do not want.

Eg, I set this Zap to America/Denver. I return to the Zap later on and it’s some other timezone. With this moving target, no wonder I can’t figure out a solution.

 

Userlevel 7
Badge +14

@donovanwatts 

If you suspect an issue with that Zap setting, then try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 4
Badge +2

Filed one just now. Thanks for the nudge, Troy.

Userlevel 4
Badge +2

@Troy Tessalone any ideas why the Data in would start as ‘2023-11-21T03:00:00-0000’ yet the Data out changes the ‘3’ to a ‘2’?

KVyiH9Qq9aGCOlRSAtaBwqi1_MiB35pibx-YBTaj5BWZTWve-XbElj1GgXTdO7xkYqvEl-m951nxNdMbYWHccc09vpk4GM1DDoXX5vwxmSRO7cf0Ai24UceSUmO5EsNm5zHXCEoKx340jno-jnPBS-M

 

 

Userlevel 7
Badge +14

@donovanwatts 

We would need to see screenshots with how the Zap step is configured.

Userlevel 4
Badge +2

Does this help?

 

Userlevel 7
Badge +14

@donovanwatts 

Previous screenshot showed a time zone offset value. (-06:00)

 

 

New screenshot shows a timestamp value without the time zone offset.

 

Reply