Best answer

Zapier Triggers before "Last modified Time" Airtable

  • 17 February 2023
  • 5 replies
  • 221 views

Userlevel 1
Badge

I have a few Zaps that run on “last Modified Time” within Airtable when a new record or updated record is created. 

problem is two are triggering before the “last modified time” is activated - so its causing a duplication of automations and burning my zap counts for the month.

My air-table is set up to first check mark what automations i need that will then filter the records into new views and then once in the view i check mark the automation to run which corresponds with the “last modified time” as described in my zap

Ive tried limiting the view but that triggers when the records enters that view

ive included a screen shot incase anyone can help but wanted to see fi any users have a similar problem with “last modified time” not actually working the way it should 


 

icon

Best answer by Troy Tessalone 17 February 2023, 03:48

View original

5 replies

Userlevel 7
Badge +14

Hi @Rlaurence83 

Good question.

You may need to adjust your View Filter conditions to prevent new/existing record from both triggering the Zap.

 

Also, you can further control your Last Modified field by limiting it to watch specific fields.

 

Otherwise, you can use Airtable Automations to have more control over trigger the Zap:

 

Userlevel 7
Badge +11

Hey @Rlaurence83!

EDIT: Troy got to it just before me and offers some great tips :)

I’m not 100% sure I’m following what your Airtable workflow is. Could you clarify what the desired outcome is and how you’ve got Airtable set up?

Is the column you’re using for “last modified time” do you have it set up for all editable fields or specific fields?

Thanks!

Userlevel 1
Badge

Hey nick its set for a specific field.



I have a “all production” view that acts as the main source for all records. When i check mark “description needed” it will then filter into the next view. I am then checking “transcribe to text” which triggers the automation. It works well every time 

 

The issue is the zap will trigger when the record enters the view and again i checked the “transcribe to text” which is the last modified time for my zap. so thats why im confused.

its not a big deal but does use double the zaps intended for the automation as its ran twice. The first zap gives me different result as i require other process to happen first before i trigger the transcribe to text.

 

Hope this make sense - ive included some screen shots 

 

 

 

Userlevel 7
Badge +14

@Rlaurence83 

Try changing the View used in the Zap trigger to have Filter conditions that match for the records you want to trigger the Zap. (e.g. Text to Transcribe = checked)

 

Userlevel 1
Badge

thanks troy - ill work on this now - legend as always :) 

Reply