Question

Zapier triggering too early clickup - google cal.

  • 16 September 2022
  • 3 replies
  • 60 views

Userlevel 1

Hi Guys,

I have a working Zap between Clickup to Google cal.

When I create a task in clickup the zap creates an event in google cal with:

-Start Date & Time
-Finish Date &Time
-Name

The trigger when when a person is assigned to a task in clickup.

Here is the rub.

While I'm creating the task, if I assign the person before adding the start and end date, even if I have not clicked save to add the task, the trigger fires and the zap fails becuase it is missing the dates.

The practical workaround is to always add the dates first before assigning the person to the task, which is fine for me, but very hard to get others to remember this specific workflow.

Is there a way around this?  So maybe the zap only fires when the ‘save’ button is pressed to create the task?

Any help would be much appreciated! 

Cheers

 


3 replies

Userlevel 7
Badge +11

Hey @jamesmac!

Question: are you adding a task like this:

or like this:

I’m wondering if one would work differently from the other.

Possible Workaround

If you can’t get the ClickUp trigger to work with either of those methods, you can set up the Zap with a Webhooks by Zapier trigger…

 

then use that URL in a ClickUp automation:

 

That should let you control things more granularly :)

Userlevel 1

ohh, thanks for the reply, 

I’ve tried adding tasks in what I think are all the different way, from the home area, by pressing ‘t’ by clicking on + new task.

So I guess the webhooks are the thing to try!  Thanks for the info, I'll report back once I've tried this.

Userlevel 7
Badge +9

Hey @jamesmac! Were you able to try out Nick’s webhook workaround? Let us know!

Reply